Bug 124816 - GDB Errors under Kdevelop
GDB Errors under Kdevelop
Status: CLOSED DUPLICATE of bug 123907
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elena Zannoni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-30 14:01 EDT by Chris Micallef
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Micallef 2004-05-30 14:01:21 EDT
Hi when I place a breakpoint under kdevelop 3 and start debug I get 
the following error and gdb stops : "Error while reading shared 
library symbols:: No such file or directory", This can be reproduced 
by creating a simpile KDE Application with kdevelop 3 and place 
breakpoint somewhere in main and start debug.
Comment 1 Chris Micallef 2004-05-30 14:02:09 EDT
/bin/sh -c /home/chris/test/debug/libtool 
gdb /home/chris/test/debug/src/test -fullname -nx -quiet 
(gdb) set edit off  
(gdb) set confirm off  
*** Warning: inferring the mode of operation is deprecated. 
*** Future versions of Libtool will require -mode=MODE be specified. 
Using host libthread_db library "/lib/tls/libthread_db.so.1". 
(gdb)  
(gdb)  
(gdb) set print static-members off  
(gdb) tty /dev/pts/12  
(gdb) set width 0  
(gdb) set height 0  
(gdb) set stop-on 1  
(gdb) handle SIG32 pass nostop noprint  
(gdb) handle SIG43 pass nostop noprint  
(gdb) set print asm-demangle on  
(gdb) cd /home/chris/test/debug/src  
(gdb) break main.cpp:45  
Breakpoint 1 at 0x804d227: file /home/chris/test/src/main.cpp, line 
45. 
(gdb) run  
Error while mapping shared library sections: 
: Success. 
 
(gdb) backtrace  
Error while reading shared library symbols: 
: No such file or directory. 
 
[Thread debugging using libthread_db enabled] 
[New Thread -150313888 (LWP 9489)] 
Stopped due to shared library event 
#0  0x009a6480 in _dl_debug_state () from /lib/ld-linux.so.2 
#1  0x0099b961 in dl_main () from /lib/ld-linux.so.2 
#2  0x009a8e14 in _dl_sysdep_start () from /lib/ld-linux.so.2 
#3  0x0099aac0 in _dl_start () from /lib/ld-linux.so.2 
#4  0x0099a7c7 in _start () from /lib/ld-linux.so.2 
(gdb) info thread  
[New Thread -150313888 (LWP 9489)] 
  2 Thread -150313888 (LWP 9489)  0x009a6480 in _dl_debug_state () 
from /lib/ld-linux.so.2 
(gdb) frame 0  
#0  0x009a6480 in _dl_debug_state () from /lib/ld-linux.so.2 
 
Comment 2 Miloslav Trmac 2004-05-31 09:51:20 EDT

*** This bug has been marked as a duplicate of 123907 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.