Bug 1248168 - [Docs] [Director] Hostname mapping to 127.0.0.1 causes install failure
[Docs] [Director] Hostname mapping to 127.0.0.1 causes install failure
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
Director
Unspecified Unspecified
medium Severity medium
: y2
: 7.0 (Kilo)
Assigned To: Dan Macpherson
: Documentation
Depends On:
Blocks: 1238779
  Show dependency treegraph
 
Reported: 2015-07-29 14:56 EDT by Chris Dearborn
Modified: 2015-12-15 23:57 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 23:57:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Dearborn 2015-07-29 14:56:21 EDT
Description of problem:
The documentation states:
==================
An entry for the system’s FQDN hostname is also needed in /etc/hosts. For example, if the system is named myhost.mydomain, /etc/hosts should have an entry like:

127.0.0.1   myhost.mydomain
==================

But mapping the FQDN to the loopback address causes "openstack undercloud install" to fail with the following error:

Error: Could not run: Could not retrieve facts for director-r13: no address for director-r13

The FQDN should apparently be mapped to the external/public IP address.  The docs need to be updated so that it indicates a change to /etc/hosts that does not cause the installer to fail.

Version-Release number of selected component (if applicable):
Beta 2

How reproducible:
See below.

Steps to Reproduce:
1. Add the FQDN to the 127.0.0.1 entry in /etc/hosts per the docs.
2. Run "openstack undercloud install"

Actual results:
Install errors out with above error message.

Expected results:
Install should succeed.

Additional info:
In this case, the Director node was installed with hostname: director-r13.rcbd.lab.
"hostname" returns the FQDN.
"hostname --fqdn" returns "localhost".
"dnsdomainname" returns nothing.
"nisdomainname" returns nothing.
"domainname" returns nothing.
"ping `hostname`" works.
"ping `hostname --short`" does not work.
Comment 3 Alexander Chuzhoy 2015-07-29 15:10:09 EDT
This never happens on my setup:

1. Could you please paste the /etc/hosts after you've added the hostname
2. Did you change the hostname after the OS was installed?
Comment 4 Chris Dearborn 2015-07-29 15:16:22 EDT
/etc/hosts:
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4 director-r13.rcbd.lab
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

No, I did not change the hostname after system install.  After the failure occurred, I did try the hostnamectl commands in the docs, then reran the install and produced the same failure.
Comment 5 Alexander Chuzhoy 2015-07-29 15:43:49 EDT
ok,
my host is registered in DNS, so:
1. pinging `hostname -f` tries 127.0.0.1
2. pinging `hostname -s` tries the IP registered in DNS. I have the respective "search domainname" line in my /etc/resolv.conf file.
Comment 6 Chris Dearborn 2015-07-29 15:55:17 EDT
Not sure what you are asking for.

My host is not registered in DNS.
My resolv.conf does not contain a "domain" or "search" line
Comment 8 Andrew Dahms 2015-08-03 20:47:44 EDT
Updated flags.
Comment 9 Andrew Dahms 2015-08-30 19:35:45 EDT
Assigning to Dan for review.
Comment 10 Dan Macpherson 2015-09-07 21:22:38 EDT
Hi Chris,

The problem is because the director uses the first hostname for 127.0.0.1. So currently you hosts file includes:

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4 director-r13.rcbd.lab

But it should be 

127.0.0.1   director-r13.rcbd.lab localhost localhost.localdomain localhost4 localhost4.localdomain4

We have bug open for this issue:

https://bugzilla.redhat.com/show_bug.cgi?id=1254370

And a fix is currently being implemented in this docs.

- Dan
Comment 11 Dan Macpherson 2015-09-23 01:25:38 EDT
Hi Chris,

I've pushed out a fix that should rectify the hostname issues:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Setting_the_Hostname_for_the_System.html

Can you verify if the new hostname order works for you?
Comment 12 Chris Dearborn 2015-12-02 12:48:45 EST
Was just able to verify it.  Working great for me.

Note You need to log in before you can comment on or make changes to this bug.