Bug 1248186 - AttributeError: 'MDBiosRaidArrayDevice' object has no attribute '_currentSize'
AttributeError: 'MDBiosRaidArrayDevice' object has no attribute '_currentSize'
Status: CLOSED DUPLICATE of bug 1245191
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:6f18fabcf38e8da9f4858bf47db...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 16:01 EDT by My Karlsson
Modified: 2015-08-03 07:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-03 07:49:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (229.55 KB, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: anaconda.log (13.29 KB, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: dnf.log (453 bytes, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: environ (494 bytes, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: lsblk_output (3.20 KB, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: nmcli_dev_list (1.97 KB, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: os_info (451 bytes, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: program.log (21.11 KB, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: storage.log (51.91 KB, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: syslog (101.72 KB, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: ifcfg.log (4.33 KB, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details
File: packaging.log (147 bytes, text/plain)
2015-07-29 16:01 EDT, My Karlsson
no flags Details

  None (edit)
Description My Karlsson 2015-07-29 16:01:10 EDT
Description of problem:
The installer crashed immediately at the initial language selection screen without any user input.

Version-Release number of selected component:
anaconda-23.17-1

The following was filed automatically by anaconda:
anaconda 23.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 604, in currentSize
    if self._currentSize == Size(0):
  File "/usr/lib/python3.4/site-packages/blivet/devices/md.py", line 681, in _addParent
    self._size = self.currentSize
  File "/usr/lib/python3.4/site-packages/blivet/devices/lib.py", line 156, in append
    self.appendfunc(y)
  File "/usr/lib/python3.4/site-packages/blivet/devices/device.py", line 153, in _setParentList
    self._parents.append(parent)
  File "/usr/lib/python3.4/site-packages/blivet/devices/device.py", line 89, in __init__
    self.parents = parents or []
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 107, in __init__
    super(StorageDevice, self).__init__(name, parents=parents)
  File "/usr/lib/python3.4/site-packages/blivet/devices/container.py", line 63, in __init__
    super(ContainerDevice, self).__init__(*args, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/devices/md.py", line 112, in __init__
    sysfsPath=sysfsPath)
  File "/usr/lib/python3.4/site-packages/blivet/devices/md.py", line 631, in __init__
    super(MDBiosRaidArrayDevice, self).__init__(name, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 568, in addUdevDiskDevice
    sysfsPath=sysfs_path, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 721, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1660, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1597, in populate
    self._populate()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 554, in populate
    self._populator.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 279, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1123, in storageInitialize
    storage.reset()
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 171, in raise_if_error
    raise exc_info[0](exc_info[1]).with_traceback(exc_info[2])
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 116, in wait
    self.raise_if_error(name)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/timezone.py", line 76, in time_initialize
    threadMgr.wait(THREAD_STORAGE)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'MDBiosRaidArrayDevice' object has no attribute '_currentSize'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-rawhide-x86_64 quiet
dnf.rpm.log:    Jul 29 21:35:28 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc4.git0.1.fc24.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        Rawhide
Comment 1 My Karlsson 2015-07-29 16:01:15 EDT
Created attachment 1057389 [details]
File: anaconda-tb
Comment 2 My Karlsson 2015-07-29 16:01:17 EDT
Created attachment 1057390 [details]
File: anaconda.log
Comment 3 My Karlsson 2015-07-29 16:01:18 EDT
Created attachment 1057391 [details]
File: dnf.log
Comment 4 My Karlsson 2015-07-29 16:01:20 EDT
Created attachment 1057392 [details]
File: environ
Comment 5 My Karlsson 2015-07-29 16:01:21 EDT
Created attachment 1057393 [details]
File: lsblk_output
Comment 6 My Karlsson 2015-07-29 16:01:22 EDT
Created attachment 1057394 [details]
File: nmcli_dev_list
Comment 7 My Karlsson 2015-07-29 16:01:24 EDT
Created attachment 1057395 [details]
File: os_info
Comment 8 My Karlsson 2015-07-29 16:01:26 EDT
Created attachment 1057396 [details]
File: program.log
Comment 9 My Karlsson 2015-07-29 16:01:28 EDT
Created attachment 1057397 [details]
File: storage.log
Comment 10 My Karlsson 2015-07-29 16:01:31 EDT
Created attachment 1057398 [details]
File: syslog
Comment 11 My Karlsson 2015-07-29 16:01:32 EDT
Created attachment 1057399 [details]
File: ifcfg.log
Comment 12 My Karlsson 2015-07-29 16:01:33 EDT
Created attachment 1057400 [details]
File: packaging.log
Comment 13 Vojtech Trefny 2015-08-03 07:49:01 EDT

*** This bug has been marked as a duplicate of bug 1245191 ***

Note You need to log in before you can comment on or make changes to this bug.