Bug 1248187 - NetworkManager does not want to manage an Intel 7260 wireless NIC.
NetworkManager does not want to manage an Intel 7260 wireless NIC.
Status: CLOSED DUPLICATE of bug 1230223
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
22
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 16:01 EDT by Greg Scott
Modified: 2015-08-10 12:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 12:09:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Scott 2015-07-29 16:01:55 EDT
Description of problem:
My Intel 7260 wireless NIC always shows up as "Unmanaged" with nmcli. So I am unable to use nmcli to scan or connect to any WiFi access points.  This worked fine with previous versions of Fedora.

Version-Release number of selected component (if applicable):
Fedora 22 with the latest updates as of 7/29/2015

How reproducible:
Always

Steps to Reproduce:
1. Observe the problem with "nmcli device status". Device w1p1s0 is unmanaged.
2.
3.

Actual results:
See step 1 above.

Expected results:
NetworkManager should be able to manage this device.

Additional info:

/etc/NetworkManager/NetworkManager.conf is right out of the box:

[root@rapidcity-fw NetworkManager]# more NetworkManager.conf
[main]
plugins=ifcfg-rh

Here is the relevant info from nmcli device show:

GENERAL.DEVICE:                         wlp1s0
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         48:51:B7:34:88:7F
GENERAL.MTU:                            1500
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.GATEWAY:
IP6.GATEWAY:

After installation, there was no ifcfg-w1p1s0 in /etc/sysconfig/network-scripts.  This is consistent with earlier behavior.  In case something changed with F22, I created one by hand in the hopes that NetworkManager would find it and decide to manage it.  This made no difference - maybe because I gave it no UUID?.  In case this is relevant, here is what I created:

[root@rapidcity-fw network-scripts]# more ifcfg-w1p1s0
HWADDR=48:51:b7:34:88:7f
TYPE=Wireless
BOOTPROTO=dhcp
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME=w1p1s0
##UUID=da9eb3fa-3a98-4f39-81f1-7f91984c8888
ONBOOT=yes
PEERDNS=yes
PEERROUTES=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
[root@rapidcity-fw network-scripts]#

Here is the relevant output from iwconfig:

wlp1s0    IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

Here is what lspci had to say - 5 wired NIC ports and the Intel WiFi:

[root@rapidcity-fw network-scripts]# lspci
00:00.0 Host bridge: Intel Corporation Atom Processor D2xxx/N2xxx DRAM Controller (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 0b)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 02)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 02)
01:00.0 Network controller: Intel Corporation Wireless 7260 (rev c3)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
04:00.0 IDE interface: ASMedia Technology Inc. ASM1061 SATA IDE Controller (rev 01)
05:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller (rev 10)
05:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller (rev 10)
05:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller (rev 10)
[root@rapidcity-fw network-scripts]#

thanks
Comment 1 Greg Scott 2015-07-29 19:57:38 EDT
I just noticed lower case L and the digit one, "l" and "1", look almost identical.  I renamed ifcfg-w1p1s0 to ifcfg-wlp1s0 and updated the NAME= field.  Restarted NetworkManager, still no change.

I know that Intel card is working.  It finds the SSIDs being broadcast around here.  Why NetworkManager won't manage it is driving me nuts.

[root@rapidcity-fw firmware]# iwlist wlp1s0 scan
wlp1s0    Scan completed :
          Cell 01 - Address: 88:DC:96:22:2B:54
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=46/70  Signal level=-64 dBm
                    Encryption key:on
                    ESSID:"ScottFamily"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000060dc700a40b
                    Extra: Last beacon: 73ms ago
                    IE: Unknown: 000B53636F747446616D696C79
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030106
                    IE: Unknown: 0706555320010B1E
                    IE: Unknown: 2A0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1ACE111BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 331ACE111BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606071500000000000000000000000000000000000000
                    IE: Unknown: 341606071500000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0101
                    IE: Unknown: DD180050F2020101010003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0900037F01010000FF7F
          Cell 02 - Address: 30:91:8F:63:D3:C5
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=66/70  Signal level=-44 dBm
                    Encryption key:on
                    ESSID:"CenturyLink0096"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000001111afbeccd
                    Extra: Last beacon: 73ms ago
                    IE: Unknown: 000F43656E747572794C696E6B30303936
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 03010B
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A3C181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D160B080000000000000000000000000000000000000000
                    IE: Unknown: DD8F0050F204104A0001101044000102103B000103104700101DA99BA73C2E521F236A3619470C85BB1021000B546563686E69636F6C6F7210230006433230303054102400064332303030541042000F4350313435325A41303257303039361054000800060050F20400011011000D546563686E69636F6C6F72415010080002200C103C0001011049000600372A000120
                    IE: Unknown: DD090010180200F42C0000
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00

[root@rapidcity-fw firmware]#
Comment 2 Greg Scott 2015-07-29 20:52:39 EDT
Oh wow - this might be significant - buried inside /var/log/messages:

Jul 29 19:33:53 rapidcity-fw NetworkManager[684]: <info>  (wlp1s0): 'wifi' plugin not available; creating generic device

Which lead to this:

dnf install -y NetworkManager-wifi

And that solved the problem after more than 8 hours of damage to my self-esteem.

My vote from the field - it's a bug.  Pieces that used to be there by default are apparently not anymore.
Comment 3 Jirka Klimes 2015-08-10 12:09:58 EDT
NetworkManager has been split to several packages/plugins for various device types, which allows lowering NM fingerprint.
NetworkManager-wifi may not be installed on minimal installation or server by default. Then you need to install the package manually (if you require WiFi support). See bug 1230223.

*** This bug has been marked as a duplicate of bug 1230223 ***

Note You need to log in before you can comment on or make changes to this bug.