Bug 1248194 - [abrt] easytag: PictureEntry_Update(): easytag killed by SIGSEGV
[abrt] easytag: PictureEntry_Update(): easytag killed by SIGSEGV
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: easytag (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:61f5d82c48ffe87ab069ff57678...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 16:05 EDT by Timur Kristóf
Modified: 2015-09-18 15:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.4.0-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-18 15:00:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (49.04 KB, text/plain)
2015-07-29 16:05 EDT, Timur Kristóf
no flags Details
File: cgroup (190 bytes, text/plain)
2015-07-29 16:05 EDT, Timur Kristóf
no flags Details
File: core_backtrace (13.09 KB, text/plain)
2015-07-29 16:05 EDT, Timur Kristóf
no flags Details
File: dso_list (11.01 KB, text/plain)
2015-07-29 16:05 EDT, Timur Kristóf
no flags Details
File: environ (1.84 KB, text/plain)
2015-07-29 16:05 EDT, Timur Kristóf
no flags Details
File: limits (1.29 KB, text/plain)
2015-07-29 16:05 EDT, Timur Kristóf
no flags Details
File: maps (58.31 KB, text/plain)
2015-07-29 16:05 EDT, Timur Kristóf
no flags Details
File: mountinfo (3.66 KB, text/plain)
2015-07-29 16:06 EDT, Timur Kristóf
no flags Details
File: namespaces (85 bytes, text/plain)
2015-07-29 16:06 EDT, Timur Kristóf
no flags Details
File: open_fds (1.53 KB, text/plain)
2015-07-29 16:06 EDT, Timur Kristóf
no flags Details
File: proc_pid_status (1010 bytes, text/plain)
2015-07-29 16:06 EDT, Timur Kristóf
no flags Details
File: var_log_messages (449 bytes, text/plain)
2015-07-29 16:06 EDT, Timur Kristóf
no flags Details

  None (edit)
Description Timur Kristóf 2015-07-29 16:05:46 EDT
Version-Release number of selected component:
easytag-2.3.7-3.fc22

Additional info:
reporter:       libreport-2.6.1
backtrace_rating: 4
cmdline:        easytag
crash_function: PictureEntry_Update
executable:     /usr/bin/easytag
global_pid:     7868
kernel:         4.1.2-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 PictureEntry_Update at src/tag_area.c:1377
 #1 et_tag_area_display_et_file at src/tag_area.c:3239
 #2 et_application_window_display_et_file at src/application_window.c:2233
 #3 et_application_window_select_file_by_et_file at src/application_window.c:1940
 #4 et_browser_set_display_mode at src/browser.c:2752
 #5 Read_Directory at src/easytag.c:913
 #6 Browser_Tree_Node_Selected at src/browser.c:907
 #7 _g_closure_invoke_va at gclosure.c:831
 #10 _gtk_tree_selection_internal_select_node at gtktreeselection.c:1595
 #11 gtk_tree_view_real_set_cursor at gtktreeview.c:13299
Comment 1 Timur Kristóf 2015-07-29 16:05:50 EDT
Created attachment 1057402 [details]
File: backtrace
Comment 2 Timur Kristóf 2015-07-29 16:05:51 EDT
Created attachment 1057403 [details]
File: cgroup
Comment 3 Timur Kristóf 2015-07-29 16:05:53 EDT
Created attachment 1057404 [details]
File: core_backtrace
Comment 4 Timur Kristóf 2015-07-29 16:05:55 EDT
Created attachment 1057405 [details]
File: dso_list
Comment 5 Timur Kristóf 2015-07-29 16:05:56 EDT
Created attachment 1057406 [details]
File: environ
Comment 6 Timur Kristóf 2015-07-29 16:05:57 EDT
Created attachment 1057407 [details]
File: limits
Comment 7 Timur Kristóf 2015-07-29 16:05:59 EDT
Created attachment 1057408 [details]
File: maps
Comment 8 Timur Kristóf 2015-07-29 16:06:01 EDT
Created attachment 1057409 [details]
File: mountinfo
Comment 9 Timur Kristóf 2015-07-29 16:06:02 EDT
Created attachment 1057410 [details]
File: namespaces
Comment 10 Timur Kristóf 2015-07-29 16:06:03 EDT
Created attachment 1057411 [details]
File: open_fds
Comment 11 Timur Kristóf 2015-07-29 16:06:04 EDT
Created attachment 1057412 [details]
File: proc_pid_status
Comment 12 Timur Kristóf 2015-07-29 16:06:06 EDT
Created attachment 1057413 [details]
File: var_log_messages
Comment 13 David King 2015-08-24 17:22:05 EDT
I pushed a couple of patches upstream which may fix the problem, which seems to be an empty image within a tag:

https://git.gnome.org/browse/easytag/commit/?id=7f26078fc55d9dde8c9ccd0cad7d3210a8390bf4
https://git.gnome.org/browse/easytag/commit/?id=0d265c866d29c541e4c1d3c32e3995503a72c0a2

Do you know exactly which file causes the problem (probably something under "/home/Timur/Downloads/t/Van Canto/2011 - Break The Silence" given the backtrace), and can you send a copy (or link) to me via email so that I can test the changes? Thanks!
Comment 14 Fedora Update System 2015-08-29 07:08:41 EDT
easytag-2.4.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14540
Comment 15 Fedora Update System 2015-08-29 09:57:18 EDT
easytag-2.4.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14552
Comment 16 Fedora Update System 2015-09-01 05:58:52 EDT
easytag-2.4.0-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update easytag'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14552
Comment 17 Fedora Update System 2015-09-01 06:05:12 EDT
easytag-2.4.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update easytag'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14540
Comment 18 Timur Kristóf 2015-09-01 06:06:56 EDT
@David, thanks for the patch. I no longer have those files, but will try to see if the issue is fixed.
Comment 19 Fedora Update System 2015-09-09 19:20:00 EDT
easytag-2.4.0-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2015-09-18 15:00:29 EDT
easytag-2.4.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.