Bug 1248200 - drop circular dependency device-mapper-libs → device-mapper
drop circular dependency device-mapper-libs → device-mapper
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 16:18 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2015-07-29 18:50 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 18:50:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2015-07-29 16:18:37 EDT
Description of problem:
This dependency pulls in device-mapper for any packages linking to the device mapper libs. According to the changelog, this was done because of udev rules, but the rules as in device-mapper, so the dependency is not necessary.

Version-Release number of selected component (if applicable):
device-mapper-1.02.102-2.fc23.x86_64
Comment 1 Alasdair Kergon 2015-07-29 18:50:54 EDT
This is still all correct as far as I can see.

If you are using udev on your system, core libdevmapper functionality relies upon those udev rules e.g. to create new device nodes in /dev.  The udev rules in turn use dmsetup.

The libs got separated into a different package because of multilib.

Note You need to log in before you can comment on or make changes to this bug.