Bug 124828 - Running SLIME in emacs with SBCL causes system to lock up
Running SLIME in emacs with SBCL causes system to lock up
Status: CLOSED DUPLICATE of bug 124074
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-30 17:24 EDT by Warren L. Rutledge
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren L. Rutledge 2004-05-30 17:24:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040515 Firefox/0.8

Description of problem:
There may be a condition where nptl and the 2.6 kernel are causing
problems.

I use the SLIME package under GNU emacs to work with lisp.  I am using
SBCL as my preferred lisp package.  SBCL has been compiled with nptl
enabled.

This package worked under FC1 and the 2.4 kernel.  However, taking my
same .emacs file and running under FC2 causes the system to lock up
during the initialization of the SWANK portion of SLIME.  There is
also some discussion on this topic under comp.lang.lisp, where the
general consensus is that it is the use of nptl in SBCL and the 2.6
kernel that is causing the problem.

I have duplicated this problem on two different hosts.  One of those
hosts acts as a gateway for my home network.  When the lock up
happened, I was unable to get any response from the keyboard, mouse,
or even by trying to ssh to the box.  Interestingly enough though, the
box continued to act as a gateway even though all other processing
appeared to be dead so the entire kernel is not locked up.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1.Add the SLIME package to your local elisp directory
(http://common-lisp.net/project/slime/)
2.Install SBCL (SBCL 0.8.10 is what I'm using with nptl)
3.From emacs start slime (M-x slime) 
    

Actual Results:  The inferior lisp starts up and you see some status
messages scroll by and then the system locks up hard.

Expected Results:  Under FC1, it starts up perfectly.

Additional info:
Comment 1 Dave Jones 2004-05-31 17:57:38 EDT
this smells like a dupe, please reopen if this isn't the case.


*** This bug has been marked as a duplicate of 124074 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.