Bug 1248294 - nano libc is not included in package
nano libc is not included in package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: arm-none-eabi-newlib (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 23:53 EDT by Johnny Robeson
Modified: 2015-09-24 10:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.2.0-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 01:13:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated version of the spec file (4.39 KB, text/plain)
2015-07-30 22:27 EDT, Johnny Robeson
no flags Details

  None (edit)
Description Johnny Robeson 2015-07-29 23:53:12 EDT
Description of problem:

I'm trying to build an application against the Nordic Semiconductor SDK, and fails to build my application with 

/usr/lib/gcc/arm-none-eabi/4.9.2/../../../../arm-none-eabi/bin/ld: cannot find -lc_nano

I looked inside the files owned by this package, and there is a libc.a, but not libc_nano.a.

It does include the nano.specs file for each arm architecture supported by this lib, but the library itself doesn't seem to be built by this application.

The ubuntu equivalent package does include these files as seen here: http://packages.ubuntu.com/vivid/all/libnewlib-arm-none-eabi/filelist

How reproducible:
every time.

Steps to Reproduce:
1. attempt to build an application that uses -lc and includes nano.specs 
2.
3.

Actual results:

fails to build with :

/usr/lib/gcc/arm-none-eabi/4.9.2/../../../../arm-none-eabi/bin/ld: cannot find -lc_nano

Expected results:

successfully builds

Additional info:
Comment 1 Johnny Robeson 2015-07-30 22:26:16 EDT
I've got a work in progress version of this, just so you can see how it's done.

I went through Debian, Ubuntu, and Arch's packages to see how they handled this.

I've made some other changes to the spec file in the process, so it'd be nice if we could meet on IRC or some similar place to talk about them. Particularly I'd like to talk about some of the ./configure flags. I've added comments in the spec that mentions the specific flags.
Comment 2 Johnny Robeson 2015-07-30 22:27:34 EDT
Created attachment 1057899 [details]
updated version of the spec file

It's not a patch, because there are too many initial irrelevant changes.
Comment 3 Michal Hlavinka 2015-08-31 10:35:57 EDT
thanks
Comment 4 Johnny Robeson 2015-08-31 15:21:06 EDT
so what do you think about these parts? I was hoping to discuss them. I can't say I'm familiar with the, but is there any reason we don't use those options?

+# ARCH AND UBUNTU HAVE
+# --enable-newlib-io-long-long \
+# --enable-newlib-register-fini \
+# ARCH AND UBUNTU DON'T HAVE
+# --enable-interwork \
+# --enable-multilib \
Comment 5 Michal Hlavinka 2015-09-01 07:31:03 EDT
I want to keep the options that ubuntu does not have:
> --enable-interwork      allows ARM and Thumb code to be used
> --enable-multilib       build multiple versions of some libs (e.g. soft- and hardfloat, little- and big endian)

I can probably add --enable-newlib-io-long-long 

For the --enable-newlib-register-fini even in ubuntu they discussed about removing this https://answers.launchpad.net/gcc-arm-embedded/+question/227709 I did not find why they did not do it in the end.
Comment 6 Johnny Robeson 2015-09-01 17:34:28 EDT
that sounds good to me. Honestly I didn't know anything about this lib.. I was just trying to make it work :)
Comment 7 Johnny Robeson 2015-09-01 17:35:01 EDT
just remove those comments once you've decided
Comment 8 Fedora Update System 2015-09-04 05:19:45 EDT
arm-none-eabi-gcc-cs-5.2.0-2.fc23 arm-none-eabi-newlib-2.2.0_1-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15077
Comment 9 Johnny Robeson 2015-09-04 05:48:49 EDT
is it ok to close this now?
Comment 10 Michal Hlavinka 2015-09-04 06:18:00 EDT
(In reply to Johnny Robeson from comment #9)
> is it ok to close this now?

No. It will be automatically closed by update system once update passes testing and gets into stable update repository.
Comment 11 Fedora Update System 2015-09-04 19:18:42 EDT
arm-none-eabi-gcc-cs-5.2.0-2.fc21, arm-none-eabi-newlib-2.2.0_1-6.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update arm-none-eabi-gcc-cs arm-none-eabi-newlib'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15075
Comment 12 Fedora Update System 2015-09-04 19:20:25 EDT
arm-none-eabi-gcc-cs-5.2.0-2.fc22, arm-none-eabi-newlib-2.2.0_1-6.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update arm-none-eabi-gcc-cs arm-none-eabi-newlib'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15076
Comment 13 Fedora Update System 2015-09-04 19:22:27 EDT
arm-none-eabi-gcc-cs-5.2.0-2.fc23, arm-none-eabi-newlib-2.2.0_1-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update arm-none-eabi-gcc-cs arm-none-eabi-newlib'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15077
Comment 14 Fedora Update System 2015-09-24 01:13:35 EDT
arm-none-eabi-gcc-cs-5.2.0-2.fc23, arm-none-eabi-newlib-2.2.0_1-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2015-09-24 04:26:06 EDT
arm-none-eabi-gcc-cs-5.2.0-2.fc22, arm-none-eabi-newlib-2.2.0_1-6.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2015-09-24 10:19:15 EDT
arm-none-eabi-gcc-cs-5.2.0-2.fc21, arm-none-eabi-newlib-2.2.0_1-6.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.