Bug 1248303 - Can't load helloworld-brms-module when import helloworld-bpms-project
Can't load helloworld-brms-module when import helloworld-bpms-project
Status: CLOSED DUPLICATE of bug 1200413
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
medium Severity medium
: ---
: 6.2.0
Assigned To: Petr Široký
Tomas David
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 00:38 EDT by Ryan Zhang
Modified: 2016-04-19 07:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 07:24:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Zhang 2015-07-30 00:38:38 EDT
Description of problem:
This seems to me a regression. I remember it has been fixed in bpms 6.1.x.
The quickstart runs ok. But there are  errors reports in console and server.log

I am trying to run bpms-project quickstarts, but it tried to load brms quickstart automatically. 

The error stack shown as:
12:28:42,204 ERROR [org.drools.compiler.kie.builder.impl.AbstractKieModule] (http-/127.0.0.1:8080-6) Unable to build KieBase, could not find include: helloworldKBase
12:28:42,208 INFO  [org.kie.scanner.embedder.MavenEmbedderUtils] (http-/127.0.0.1:8080-6) Not in OSGi: using plexus based maven parser
12:28:42,283 ERROR [org.kie.workbench.common.services.backend.builder.BuildServiceImpl] (http-/127.0.0.1:8080-6) org.kie.scanner.embedder.MavenEmbedderException: Failed to read artifact descriptor for org.jboss.quickstarts.brms:helloworld-brms-kmodule:jar:1.0.0: java.lang.RuntimeException: org.kie.scanner.embedder.MavenEmbedderException: Failed to read artifact descriptor for org.jboss.quickstarts.brms:helloworld-brms-kmodule:jar:1.0.0
	at org.kie.scanner.embedder.MavenProjectLoader.parseMavenPom(MavenProjectLoader.java:57) [kie-ci-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at org.kie.scanner.embedder.MavenProjectLoader.parseMavenPom(MavenProjectLoader.java:49) [kie-ci-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at org.kie.scanner.ArtifactResolver.getResolverFor(ArtifactResolver.java:127) [kie-ci-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at org.kie.scanner.KieModuleMetaDataImpl.<init>(KieModuleMetaDataImpl.java:83) [kie-ci-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at org.kie.scanner.KieModuleMetaData$Factory.newKieModuleMetaData(KieModuleMetaData.java:45) [kie-ci-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at org.kie.workbench.common.services.backend.builder.Builder.build(Builder.java:190) [kie-wb-common-services-backend-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at org.kie.workbench.common.services.backend.builder.BuildServiceImpl.doBuild(BuildServiceImpl.java:174) [kie-wb-common-services-backend-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at org.kie.workbench.common.services.backend.builder.BuildServiceImpl.build(BuildServiceImpl.java:85) [kie-wb-common-services-backend-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at org.kie.workbench.common.services.backend.builder.BuildServiceImpl$Proxy$_$$_WeldClientProxy.build(BuildServiceImpl$Proxy$_$$_WeldClientProxy.java) [kie-wb-common-services-backend-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_17]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_17]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_17]
	at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_17]
	at org.jboss.errai.bus.server.io.AbstractRPCMethodCallback.invokeMethodFromMessage(AbstractRPCMethodCallback.java:48) [errai-bus-3.2.0.CR1-redhat-1.jar:3.2.0.CR1-redhat-1]
	at org.jboss.errai.bus.server.io.ValueReplyRPCEndpointCallback.callback(ValueReplyRPCEndpointCallback.java:22) [errai-bus-3.2.0.CR1-redhat-1.jar:3.2.0.CR1-redhat-1]
	at org.jboss.errai.bus.server.io.RemoteServiceCallback.callback(RemoteServiceCallback.java:54) [errai-bus-3.2.0.CR1-redhat-1.jar:3.2.0.CR1-redhat-1]
	at org.jboss.errai.cdi.server.CDIExtensionPoints$2.callback(CDIExtensionPoints.java:396) [errai-weld-integration-3.0.6.Final-redhat-1.jar:3.0.6.Final-redhat-1]
	at org.jboss.errai.bus.server.DeliveryPlan.deliver(DeliveryPlan.java:47) [errai-bus-3.2.0.CR1-redhat-1.jar:3.2.0.CR1-redhat-1]
	at org.jboss.errai.bus.server.ServerMessageBusImpl.sendGlobal(ServerMessageBusImpl.java:296) [errai-bus-3.2.0.CR1-redhat-1.jar:3.2.0.CR1-redhat-1]
	at org.jboss.errai.bus.server.SimpleDispatcher.dispatchGlobal(SimpleDispatcher.java:46) [errai-bus-3.2.0.CR1-redhat-1.jar:3.2.0.CR1-redhat-1]
	at org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.java:97) [errai-bus-3.2.0.CR1-redhat-1.jar:3.2.0.CR1-redhat-1]
	at org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.java:114) [errai-bus-3.2.0.CR1-redhat-1.jar:3.2.0.CR1-redhat-1]
	at org.jboss.errai.bus.server.servlet.DefaultBlockingServlet.doPost(DefaultBlockingServlet.java:142) [errai-bus-3.2.0.CR1-redhat-1.jar:3.2.0.CR1-redhat-1]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:754) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-2.jar:1.0.2.Final-redhat-2]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-2.jar:1.0.2.Final-redhat-2]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.uberfire.ext.security.server.SecureHeadersFilter.doFilter(SecureHeadersFilter.java:53) [uberfire-servlet-security-0.7.0.Beta3-redhat-1.jar:0.7.0.Beta3-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.uberfire.ext.security.server.SecurityIntegrationFilter.doFilter(SecurityIntegrationFilter.java:45) [uberfire-servlet-security-0.7.0.Beta3-redhat-1.jar:0.7.0.Beta3-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:231) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:512) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50) [jboss-as-jpa-7.5.0.Final-redhat-21.jar:7.5.0.Final-redhat-21]
	at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50) [jboss-as-jpa-7.5.0.Final-redhat-21.jar:7.5.0.Final-redhat-21]
	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169) [jboss-as-web-7.5.0.Final-redhat-21.jar:7.5.0.Final-redhat-21]
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:150) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:419) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:344) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:854) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:926) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_17]
Caused by: org.kie.scanner.embedder.MavenEmbedderException: Failed to read artifact descriptor for org.jboss.quickstarts.brms:helloworld-brms-kmodule:jar:1.0.0
	at org.kie.scanner.embedder.MavenEmbedder.readProject(MavenEmbedder.java:265) [kie-ci-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	at org.kie.scanner.embedder.MavenProjectLoader.parseMavenPom(MavenProjectLoader.java:55) [kie-ci-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	... 47 more
Caused by: org.eclipse.aether.resolution.ArtifactDescriptorException: Failed to read artifact descriptor for org.jboss.quickstarts.brms:helloworld-brms-kmodule:jar:1.0.0
	at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:349) [maven-aether-provider-3.2.2.jar:3.2.2]
	at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.readArtifactDescriptor(DefaultArtifactDescriptorReader.java:231) [maven-aether-provider-3.2.2.jar:3.2.2]
	at org.eclipse.aether.internal.impl.DefaultDependencyCollector.resolveCachedArtifactDescriptor(DefaultDependencyCollector.java:525) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultDependencyCollector.getArtifactDescriptorResult(DefaultDependencyCollector.java:509) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:409) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:363) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultDependencyCollector.process(DefaultDependencyCollector.java:351) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:254) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultRepositorySystem.collectDependencies(DefaultRepositorySystem.java:316) [aether-impl-1.0.0.v20140518.jar:]
	at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:159) [maven-core-3.2.2.jar:3.2.2]
	at org.apache.maven.project.DefaultProjectBuilder.resolveDependencies(DefaultProjectBuilder.java:202) [maven-core-3.2.2.jar:3.2.2]
	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:175) [maven-core-3.2.2.jar:3.2.2]
	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:114) [maven-core-3.2.2.jar:3.2.2]
	at org.kie.scanner.embedder.MavenEmbedder.readProject(MavenEmbedder.java:261) [kie-ci-6.3.0.Beta2-redhat-1.jar:6.3.0.Beta2-redhat-1]
	... 48 more
Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: Failure to transfer org.jboss.quickstarts.brms:helloworld-brms-kmodule:pom:1.0.0 from http://localhost:8080/business-central/maven2/ was cached in the local repository, resolution will not be reattempted until the update interval of guvnor-m2-repo has elapsed or updates are forced. Original error: Could not transfer artifact org.jboss.quickstarts.brms:helloworld-brms-kmodule:pom:1.0.0 from/to guvnor-m2-repo (http://localhost:8080/business-central/maven2/): Unauthorized (401)
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223) [aether-impl-1.0.0.v20140518.jar:]
	at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:334) [maven-aether-provider-3.2.2.jar:3.2.2]
	... 61 more
Caused by: org.eclipse.aether.transfer.ArtifactTransferException: Failure to transfer org.jboss.quickstarts.brms:helloworld-brms-kmodule:pom:1.0.0 from http://localhost:8080/business-central/maven2/ was cached in the local repository, resolution will not be reattempted until the update interval of guvnor-m2-repo has elapsed or updates are forced. Original error: Could not transfer artifact org.jboss.quickstarts.brms:helloworld-brms-kmodule:pom:1.0.0 from/to guvnor-m2-repo (http://localhost:8080/business-central/maven2/): Unauthorized (401)
	at org.eclipse.aether.internal.impl.DefaultUpdateCheckManager.newException(DefaultUpdateCheckManager.java:238) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultUpdateCheckManager.checkArtifact(DefaultUpdateCheckManager.java:206) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.gatherDownloads(DefaultArtifactResolver.java:585) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:503) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:421) [aether-impl-1.0.0.v20140518.jar:]


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Start BPMsuite server
2.Import jboss-brms-bpmsuite-repository
3.Build and deploy "bpms-project" from "Project Authoring" via Business-central console
4. The error appreas in terminal console and also in server.log.

Actual results:


Expected results:


Additional info:
Comment 2 Petr Široký 2015-07-30 04:55:50 EDT
Looks very similar to https://bugzilla.redhat.com/show_bug.cgi?id=1200413. I will need to investigate more to see if it indeed is the same issue.
Comment 3 Ryan Zhang 2016-04-19 07:24:03 EDT

*** This bug has been marked as a duplicate of bug 1200413 ***

Note You need to log in before you can comment on or make changes to this bug.