Bug 1248307 - Where did RDMA's support for RDMA over NFS go?
Where did RDMA's support for RDMA over NFS go?
Status: CLOSED DUPLICATE of bug 1310757
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rdma (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Honggang LI
Infiniband QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 00:59 EDT by jamespharvey20
Modified: 2017-01-24 04:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-05 00:51:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jamespharvey20 2015-07-30 00:59:08 EDT
Back on v6 there was:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Storage_Administration_Guide/nfs-rdma.html

/etc/rdma/rdma.conf could have NFSoRDMA_LOAD=yes, and have NFSoRDMA_PORT set.

rdma doesn't have these options anymore.

Did they go elsewhere?

Kernel module svcrdma needs to be loaded on the server, and xprtrdma needs to be loaded on the client.

On the server, /proc/fs/nfsd/portlist still needs a port.
Comment 1 jamespharvey20 2015-07-30 01:01:57 EDT
... This is for Fedora, which uses RDMA too.  :-)
Comment 3 jamespharvey20 2015-07-30 03:48:18 EDT
I found this previous bug report:

https://bugzilla.redhat.com/show_bug.cgi?id=736754

The last message there says everyone seems to agree to move NFSoRDMA to another package, but there wasn't agreement on where it should go.  Then there were no more comments.

It mentions nfs-utils, nfs-rdma-utils, nfs-utils-rdma.

I don't see any packages named nfs-rdma-utils or nfs-utils-rdma.  Looking at the current source rpm nfs-utils, I don't see any systemd .service files containing a string of rdma, and I don't see any of its etc files having any of these options, either.
Comment 6 Sachin Prabhu 2017-01-05 00:51:57 EST
There have been changes made to the Storage administration guide which provides the information you are looking for. The new version of the guide doesn't appear to have been published yet. Here is the information copied from a build of the guide.

--
8.7.5. Enabling NFS over RDMA (NFSoRDMA)
The remote direct memory access (RDMA) service works automatically in Red Hat Enterprise Linux 7 if there is RDMA-capable hardware present.
To install the rdma package, enter:
# yum install rdma
After installation, the /etc/rdma/rdma.conf file contains a line that sets XPRTRDMA_LOAD=yes by default, which requests the rdma service to load the NFSoRDMA client module.
To enable automatic loading of NFSoRDMA server modules, add SVCRDMA_LOAD=yes on a new line in /etc/rdma/rdma.conf.
RPCNFSDARGS="--rdma=20049" in the /etc/sysconfig/nfs file specifies the port number on which the NFSoRDMA service listens for clients. RFC 5667 specifies that servers must listen on port 20049 when providing NFSv4 services over RDMA.
Reboot the system after modifying the /etc/rdma/rdma.conf file for the changes to take effect.
--

*** This bug has been marked as a duplicate of bug 1310757 ***
Comment 7 Milan Navratil 2017-01-24 04:15:16 EST
The updated Enabling NFS over RDMA (NFSoRDMA) section of the Red Hat Enterprise Linux 7 Storage Administration Guide is now available on the Customer Portal:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Storage_Administration_Guide/nfs-serverconfig.html#nfs-rdma

Note You need to log in before you can comment on or make changes to this bug.