Bug 124831 - group mailman does not exist - using root
group mailman does not exist - using root
Status: CLOSED DUPLICATE of bug 125421
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-30 20:31 EDT by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2004-05-30 20:31:31 EDT
Description of problem:
When I installed mailman from FC2 I get a lot of warnings
about group mailman not existing, which doesn't seem nice.

Version-Release number of selected component (if applicable):
mailman-2.1.4-4
mailman-2.1.5-3

How reproducible:
every time

Steps to Reproduce:
1. # rpm -iv mailman-2.1.4-4
  
Actual results:
Preparing packages for installation...
mailman-2.1.5-3
Warning: group mailman does not exist - using root
Warning: group mailman does not exist - using root
Warning: group mailman does not exist - using root
Warning: group mailman does not exist - using root
Warning: group mailman does not exist - using root
Warning: group mailman does not exist - using root
:
:
:       <one for every file in the pkg manifest I guess>
:
:
:
Warning: group mailman does not exist - using root
Warning: group mailman does not exist - using root
crontab:  user `mailman' unknown


Expected results:
No warnings or errors.

Additional info:
As noted the same also happens with the latest mailman package in
FC devel.

Marking this severity security just in case this might have any
security inplications.
Comment 1 Jens Petersen 2004-05-31 01:01:36 EDT
I wonder if this is somehow related to selinux, since several
people on #fedora-devel told me that they can't reproduce this...
Comment 2 John Dennis 2004-06-01 10:46:35 EDT
Was that a typo? Did you mean they can reproduce it?

I've heard reports of this before and I believe with other packages
besides mailman that depend on specific system user accounts. Since
the rpm in each instance does in fact create the user my assumption is
also this is an selinux issue. I'm adding Dan Walsh to the cc list,
hopefully Dan can shed some light on whether selinux will prevent rpm
from creating system user accounts.
Comment 3 Jens Petersen 2004-06-06 11:31:31 EDT
In the meantime I managed to accidently delete the installation
where I was experiencing this problem. )-:

As I recall it was failing on the groupadd command in %pre.
Btw I installed the policy pkg on the machine to get rid of the
missing selinux files warnings when installing rpm packages...
Comment 4 Jens Petersen 2004-06-06 11:36:49 EDT
To comment 2 - no, no typo: they could reproduce they said.  Presumably
they're not running selinux though.

Forgot to mention in comment 3, that installing the policy pkg
put my machine in permissive mode afaict after the next reboot.
(If this is the case, it doesn't seem very nice behaviour to me.)
Comment 5 Jens Petersen 2004-06-06 11:47:10 EDT
Ugh: that should read "they could *not* reproduce".  Sorry for the
confusion.
Comment 6 Bob Cochran 2004-06-10 00:35:33 EDT
I can confirm the problem. This happened to me on a freshly installed
system with SELinux disabled.
Comment 7 John Dennis 2004-06-10 11:05:56 EDT
For those of you seeing this problem are you using nis to manage your
groups?

What does the group line in /etc/nsswitch.conf say?

What do these commands return?

% grep '^mailman:' /etc/group
% getent group mailman
% getent group 41
Comment 8 Jens Petersen 2004-06-21 21:49:13 EDT
I don't use nis fwiw.
Comment 9 John Dennis 2004-08-30 16:11:20 EDT

*** This bug has been marked as a duplicate of 125421 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:03:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.