Bug 1248368 - mock-config ignores --arch param when the --target is specified
mock-config ignores --arch param when the --target is specified
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike McLean
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 03:51 EDT by Tomas Mlcoch
Modified: 2016-03-22 03:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-22 03:11:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (746 bytes, application/mbox)
2015-07-30 03:51 EDT, Tomas Mlcoch
no flags Details

  None (edit)
Description Tomas Mlcoch 2015-07-30 03:51:43 EDT
Created attachment 1057550 [details]
Patch

Since a ticket opened at fedorahosted (https://fedorahosted.org/koji/ticket/301) wasn't noticed and bug reported by Jaroslav (https://bugzilla.redhat.com/show_bug.cgi?id=1161610) was ignored, I'm opening a bug for issue again.

mock-config ignores --arch option and generate invalid mock config files that contains incorrect statements:

config_optstarget_arch? = None config_optsyum.conf? = '..SNIP..baseurl=URL_WITH_ARCH_NONE..SNIP..' 


Patch attached
Comment 1 Jan Kurik 2016-02-24 08:29:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Fedora Admin XMLRPC Client 2016-03-10 09:46:25 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Tomas Mlcoch 2016-03-22 03:11:09 EDT
Pull-request with fix has been just merged:
​https://pagure.io/koji/pull-request/26

Note You need to log in before you can comment on or make changes to this bug.