Bug 1248378 - oscap does not handle non-decimal version of OVAL
oscap does not handle non-decimal version of OVAL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openscap (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Šimon Lukašík
Marek Haicman
:
Depends On: 1248380 1202868 1248375
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 04:02 EDT by Ján Rusnačko
Modified: 2016-05-10 16:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: openscap-1.2.7-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: The XSD schemas released by NIST and shipped within OpenSCAP project did only allowed for OVAL versions in form of X.Y. While the latest release of OVAL language 5.11.1 is in form of X.Y.Z Consequence: Some OpenSCAP commands, like DataStream compose (oscap ds sds-compose) were not working for content of the latest OVAL version. Fix: XSD schema incorporated in OpenSCAP project has been amended to allow for all known OVAL versions. Result: All OpenSCAP operations work well with latest OVAL content.
Story Points: ---
Clone Of: 1248375
Environment:
Last Closed: 2016-05-10 16:53:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ján Rusnačko 2015-07-30 04:02:25 EDT
+++ This bug was initially created as a clone of Bug #1248375 +++

Description of problem:
oscap does not handle the non-decimal version of OVAL XMLs (e.g. 5.10.1) well:

File '/home/jrusnack/workspace/tmp/result.xml' line 6: Element
'{http://oval.mitre.org/XMLSchema/oval-common-5}schema_version': '5.10.1' is not
a valid value of the atomic type 'xs:decimal'. 


Version-Release number of selected component (if applicable):
1.1.1

Steps to Reproduce:
$ oscap ds sds-compose source.xml result.xml 

where source.xml is OVAL XML with 5.10.1 version
Comment 2 Šimon Lukašík 2015-07-31 04:36:09 EDT
Fixed in upstream, easy to backport.

Relevant upstream change: https://github.com/OpenSCAP/openscap/commit/0aa1a0d02046f26935aa0f3833e7edf531662237
Comment 5 Marek Haicman 2016-01-29 08:57:28 EST
Verified fix on version openscap-1.2.8-1.el6
Comment 7 errata-xmlrpc 2016-05-10 16:53:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0806.html

Note You need to log in before you can comment on or make changes to this bug.