Bug 1248388 - no overcloudrc file after deployment via UI
no overcloudrc file after deployment via UI
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
Director
Unspecified Linux
unspecified Severity high
: async
: Director
Assigned To: Brad P. Crochet
Ola Pavlenko
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 04:09 EDT by Ola Pavlenko
Modified: 2015-08-13 16:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-tuskar-ui-0.3.0-15.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 16:04:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 210102 None None None Never

  None (edit)
Description Ola Pavlenko 2015-07-30 04:09:06 EDT
Description of problem:
deployment via UI doesn't create overcloudrc file

Version-Release number of selected component (if applicable):
openstack-tuskar-ui-extras-0.0.4-1.el7ost.noarch
openstack-tuskar-ui-0.3.0-13.el7ost.noarch
rhos-release-0.65-1.noarch

How reproducible:
100%

Steps to Reproduce:
1.Use Undercloud UI to deploy openstack
2.in command line source overcloudrc file
3. access controller node

Actual results:
no overcloudrc file in /home/stack dir

Expected results:
overcloudrc exists

Additional info:
Comment 4 Omri Hochman 2015-08-13 14:56:33 EDT
Verified : openstack-tuskar-ui-0.3.0-15.el7ost .

After deploying using the UI and initializing the overcloud - I could see in the overview tab the overcloudrc information , as well I cloud click the 'Download' button and get the file.  after source the file as stack on the instack machine It seems that the overcloudrc file is valid and I could communicate correctly and use the overcloud cli.
Comment 6 errata-xmlrpc 2015-08-13 16:04:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1624

Note You need to log in before you can comment on or make changes to this bug.