Bug 124844 - Installer dropped down to text mode after applying latest upgrades to Update 2
Installer dropped down to text mode after applying latest upgrades to Update 2
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-31 04:32 EDT by Stas Goshtein
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-01 16:29:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stas Goshtein 2004-05-31 04:32:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
After applying latest up2date to ES3 Update 2 and merging them to the
tree, installations made will fail to run in graphical mode with X
start error. In /tmp/X.log there is a message about missing
liblaus.so.1 library. Comps.xml doesn't include laus-libs package at
all, so probably buildinstall won't extract the required file from
laus-libs.

Version-Release number of selected component (if applicable):
anaconda-9.1.2-2.RHEL

How reproducible:
Always

Steps to Reproduce:
1. Install ES Update 2
2. Up2date to latest packages.
3. Rebuild installer with buildinstall.
4. Try to install.
    

Actual Results:  Graphical installation failed, VESA driver not
loaded, dropped down to text mode.

Expected Results:  Graphical installation mode.

Additional info:
Comment 1 Stas Goshtein 2004-05-31 08:43:19 EDT
Another small thing - this is what /usr/share/anaconda/anaconda.conf
reads in stable version.


TitleBar                        pixmaps/anaconda_header.png
Title                           Red Hat Linux Beta
helptag                         ent
Comment 2 Jeremy Katz 2004-06-01 16:29:12 EDT
This isn't supported.  A newer laus has been released since the U2
spin of trees which splits laus into having a laus-libs package which
then also needs to be pulled into PACKAGES in
/usr/lib/anaconda-runtime/upd-instroot.
Comment 3 Stas Goshtein 2004-06-06 03:11:19 EDT
As far as I know buildinstall runs upd-instroot within itself, so
exactly no laus-libs package included there, that's the reason why it
failed. Can't you just add it to the stable tree, so updates will go
smoother.
Comment 4 Jeremy Katz 2004-06-06 23:26:24 EDT
I added it there, but that doesn't help the currently released
packages much since I'm not psychic :-)

Note You need to log in before you can comment on or make changes to this bug.