Bug 1248459 - IPA OTP Limitations for Laptop Users Needs Clarification + [Doc] [RFE] Allow smart multi step prompting when user logs in with password and token code from IPA
IPA OTP Limitations for Laptop Users Needs Clarification + [Doc] [RFE] Allow ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-System_Level_Authentication_Guide (Show other bugs)
7.1
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Aneta Šteflová Petrová
Kaushik Banerjee
: Documentation, FutureFeature
: 1249088 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 06:41 EDT by ilmostro7
Modified: 2016-11-24 03:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: "Do not use OTP authentication with laptop users in default configuration. It is recommended either to not enable OTP for laptop users at all, or to switch to LDAP. Note that switching to LDAP disables single sign-on." Consequence: It's easy to infer that there might be other reasons why "Laptop users" are not able to use OTP/single sign-on; other than the "roaming" nature of laptop use. Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 09:30:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ilmostro7 2015-07-30 06:41:29 EDT
Document URL: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System-Level_Authentication_Guide/authconfig-addl-auth.html#otp-laptop-users

Section Number and Name: 2.3.5.4. Limitations for Laptop Users

Describe the issue: The section for OTP with the IdM should be rephrased to clarify that there is no hardware-related problem with the way FreeIPA is implemented to laptops. 

Suggestions for improvement: As Alexander Bokovoy states in the FreeIPA mailing list, 

"What the documentation
tries to explain (rather poorly, I agree!) is that a roaming clients
like laptops would have some issues when OTP is the only scheme enabled
for the user.

This is solved in SSSD 1.13 and both solution and the problem are
described in detail in
https://fedorahosted.org/sssd/wiki/DesignDocs/PAMConversationForOTP"

Additional information:
Comment 2 Aneta Šteflová Petrová 2015-11-04 02:52:38 EST
*** Bug 1249088 has been marked as a duplicate of this bug. ***
Comment 3 Aneta Šteflová Petrová 2015-11-04 02:59:30 EST
The "2.3.5.4. Limitations for Laptop Users" section needs to be rewritten to include a new product feature. I'm updating this Bugzilla report accordingly and closing the other Bugzilla as duplicate.
Comment 5 Aneta Šteflová Petrová 2015-11-04 03:28:56 EST
I've updated the section. The new content is now under SME review.
Comment 6 Aneta Šteflová Petrová 2015-11-09 06:05:26 EST
To fix the problem reported in comment#0, I rewrote section "2.3.5.4. Limitations for Laptop Users", now named "2.3.5.4. Offline Authentication with OTP": the section is now clearer about the limitations for laptops and offline devices and includes documentation for offline OTP authentication.

I also updated "2.3.5. One-Time Passwords" to reflect that offline OTP authentication and GNOME Keyring integration are supported.
Comment 10 Kaleem 2015-12-07 09:27:33 EST
Verified as per comment#9.

Note You need to log in before you can comment on or make changes to this bug.