Bug 124846 - xfree86.xml is missing
xfree86.xml is missing
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-31 05:17 EDT by Sergey V. Udaltsov
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey V. Udaltsov 2004-05-31 05:17:52 EDT
Description of problem:
In /usr/X11R6/lib/X11/xkb, there is xfree86->xorg but there is no
xfree86.xml->xorg.xml. For people upgrading from FC1 (and having
XkbRules "xfree86" in XF86Config) this causes xkb errors on gnome startup.

Version-Release number of selected component (if applicable):


How reproducible:
Always
Comment 1 Mike A. Harris 2004-06-01 04:57:54 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 2 Sergey V. Udaltsov 2004-06-01 05:58:17 EDT
I am ok with marking it as dupilicate - but from that bug it is not
clear whether xfree86.xml is going to be created or not. Mike, could
you please comment on this?
Comment 3 Mike A. Harris 2004-06-01 06:40:25 EDT
We will be releasing an xorg-x11 update soon which has rpm
postinstallation scripts which remove the Options "xkbrules" line
from the config file if present.  This was actually intended to
be in the initial Fedora Core 2 release, but got left out
inadvertently.

The config file will be massaged during upgrade or install of the
xorg-x11-6.7.0-3 or later packages, so any user with this line
present in their config file prior to upgrade will have it
automatically removed after upgrade.  Likewise, our config tools
that ship with Fedora Core 2, will not write this line out to
the config file.

This gives users experiencing this problem two options to work
around the issue:

1) Rerun "system-config-display --reconfig", which will generate
   a new config file without the bad config option.  Alternatively,
   a user could hand edit the config file and remove the bad option
   by hand and restart the X server.

or

2) Users can wait until we release the 6.7.0-3 or later update and
   just upgrade to it.  This will automatically update any config
   file present.

Once users have hand edited the file, or have upgraded to our new
xorg-x11 release (once released), they should no longer see this
problem in the future again.

Since we already have a solid solution to this problem, we will not
be adding the xfree86.xml file nor a symlink between the files, as
that would prolong longer term problems related to these files when
the XKB rules file name changes upstream again.  Currently, upstream
plans on changing the name of the file to "base.xml".  Our solution
is superior to providing a compatibility kludge, since it forces
everything that uses the xkbrules file to obtain the name of it
using a published and documented API.

We were able to fix all software in the distribution to use this
API for Fedora Core 2 with the exception of one app in KDE (which
has been subsequently fixed), so users should not see this problem
occur unless their X server is misconfigured, which our pending
update will make disappear automatically.

If you would like to test our 6.7.0-3 package for this solution,
I have it available under ftp://people.redhat.com/mharris/testing/fc2
for testing purposes.

Thanks in advance.

Comment 4 Mike A. Harris 2004-06-01 06:44:39 EDT
Doh..   I just realized *after* submitting my above comment, that you
are one of the upstream developers or I wouldn't have went to that
level of detail.   ;o)

Having just realized this now, I am curious if you and Ivan think
this resolution will be adequate or not?  It may be hard to judge
for a while, since once the erratum is out, we will likely still
receive new bug reports from freshly installed systems.

Any feedback appreciated.

Thanks Sergey!
Comment 5 Sergey V. Udaltsov 2004-06-01 06:56:46 EDT
From my POV this solution is quite good. I am happy to live in the
world  without "XkbRules" lines - which would guarantee us using the
default ruleset all the time. Probably in this case you Fedora live
without the symlink I mentioned - in this case you should also remove
symlink xfree86. It should "both or none" thing anyway. If the upgrade
process guarantees removal of "XkbRules" - probably you can safely get
rid of both symlinks.

Talking about "base.xml" - I see you are going the "XKeyboardConfig"
way. Did you have a look at it? What's your impression?
Comment 6 Red Hat Bugzilla 2006-02-21 14:03:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.