Bug 124847 - X hangs after boot
X hangs after boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-31 06:12 EDT by Sebastian Bergmann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:19:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Bergmann 2004-05-31 06:12:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
I am using Fedora Core 2 on my Acer TravelMate 529TXV laptop which has
a ATI Rage Mobility P/M AGP 2x graphics chip. Sometimes the screen
stays white after boot with the X process taking up 99% of the CPU time.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Sometimes

Steps to Reproduce:
1. Boot Fedora Core 2.

Additional info:

xorg.conf:

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
        Load  "dri"
        Load  "xtrap"
        Load  "extmod"
        Load  "dbe"
        Load  "vnc"
        Load  "record"
        Load  "glx"
        Load  "freetype"
        Load  "speedo"
        Load  "type1"
        Load  "synaptics"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "de"
	Option	    "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "synaptics"
	Option	    "Protocol" "auto-dev"
	Option	    "Device" "/dev/psaux"
	Option      "MaxTapTime" "180"
	Option      "EmulateMidButtonTime" "75"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "LCD Panel 1024x768"
	HorizSync    31.5 - 48.5
	VertRefresh  40.0 - 70.0
	Option	    "dpms"
EndSection

Section "Device"
  Identifier  "Videocard0"
  Driver      "ati"
  VendorName  "ATI"
  BoardName   "Rage Mobility P/M AGP 2x"
  ChipSet     "ati"
  ChipId      0x4c4d
  ChipRev     0x64
  BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
Comment 1 juppie 2004-06-10 14:34:07 EDT
I have the same problem too...
But maybe it is because i have an 5 years old machine.
This is my system configuration:
- AMD-K6 II 450MHz.
- 128 MB intern memory
- Ali Motherboard
Comment 2 G. Vincent Castellano 2004-10-20 10:21:19 EDT
Same problem on IBM T23, hardware (from hwconf):

driver: Card:S3 Savage/IX
desc: "S3 Inc. SuperSavage IX/C SDR"
vendorId: 5333
deviceId: 8c2e
subVendorId: 1014
subDeviceId: 01fc

I can't tell what the CPU usage is, though, as I can't switch to a
text console after X hangs.  All I can do is reboot.
Comment 3 Mike A. Harris 2005-03-06 16:49:01 EST
Why are you putting these unsupported options in the config file?

  ChipId      0x4c4d
  ChipRev     0x64

Don't override ChipId and ChipRev.


Does this problem still occur with Fedora Core 3 with all updates
applied, after running "system-config-display --reconfig"?

Comment 4 Mike A. Harris 2005-03-06 16:51:23 EST
juppie, G Vincent:

Both of your bugs sound completely unrelated to the problem
reported in the initial bug report.  You all have different
video hardware.  If you still have these problems in Fedora
Core 3, with all updates applied, please file bug reports for
your Savage issue in X.Org bugzilla at http://bugs.freedesktop.org

Thanks
Comment 5 Mike A. Harris 2005-04-15 10:19:45 EDT
Fedora Core 2 support lifetime has now ended.

Upgrade to Fedora Core 3 if the problem still happens and you think
it's a bug, you can report it in X.Org bugzilla at http://bugs.freedesktop.org
in the "xorg" component.


Note You need to log in before you can comment on or make changes to this bug.