Bug 1248476 - [FCoE] ixgbe/bnx2fc FCoE disk is added as local disk after adding in Anaconda GUI
[FCoE] ixgbe/bnx2fc FCoE disk is added as local disk after adding in Anaconda...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 07:37 EDT by Radek Vykydal
Modified: 2015-11-19 03:49 EST (History)
3 users (show)

See Also:
Fixed In Version: python-blivet-0.61.15.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:49:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage.log (148.25 KB, text/plain)
2015-07-30 07:37 EDT, Radek Vykydal
no flags Details
beaker job for reproducer (822 bytes, text/plain)
2015-07-30 07:48 EDT, Radek Vykydal
no flags Details

  None (edit)
Description Radek Vykydal 2015-07-30 07:37:01 EDT
Created attachment 1057634 [details]
storage.log

After adding FCoE disk (and doing Refresh List if needed) in Anaconda GUI it is added as a local disk (not recognized as FCoE disk).

Hit with:

http://download.devel.redhat.com/nightly/RHEL-7.2-20150722.n.0/compose/Server/x86_64/os/

here:

https://beaker.engineering.redhat.com/jobs/1032884

Seems like a fallout of
https://github.com/rhinstaller/blivet/commit/0f986f932f7a9bcbd48b0b711e5b270a76b72083

Sending a patch for review.
Comment 2 Radek Vykydal 2015-07-30 07:42:37 EDT
https://github.com/rhinstaller/blivet/pull/189
Comment 3 Radek Vykydal 2015-07-30 07:48:39 EDT
Created attachment 1057636 [details]
beaker job for reproducer

To reproduce run attached beaker job.

This kickstart (not relevant to the bug) was used
http://10.34.39.2/ks/rv/ks.fcoebkr.cfg

keyboard us
lang en_US.UTF-8
timezone America/New_York --utc
rootpw chrbkrchl
clearpart --all --drives=sda
Comment 6 errata-xmlrpc 2015-11-19 03:49:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2232.html

Note You need to log in before you can comment on or make changes to this bug.