Bug 124853 - Replace kernel-source with real kernel source package
Replace kernel-source with real kernel source package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-31 07:22 EDT by Ed Avis
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-05 09:20:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2004-05-31 07:22:17 EDT
The Fedora installation CDs include a kernel-source package so that
people can rebuild their kernel in the time-honoured fashion.  But one
thing they cannot do is build the kernel that Fedora uses.  The
kernel-source package doesn't include any of the Fedora patches so
unless you want to revert to a vanilla Linux-2.6.5 it is not much use.

Instead, you could include the SRPM for the real kernel package on the
CD.  This can still be used to build an unpatched kernel for those who
want it, since it contains the pristine Linux tarball, but it can also
be used to rebuild the kernel with Fedora customizations.  Even though
it contains the extra patches, it is actually smaller than the
kernel-source package currently included because the linux-2.6.5
tarball in the SRPM uses bzip2 compression.

The kernel SRPM is smaller than kernel-source and much more useful: I
think it would be a good idea to include the SRPM instead.
Comment 1 Arjan van de Ven 2004-05-31 07:52:10 EDT
" The kernel-source package doesn't include any of the Fedora patches"

actually it does. It's the exact same source we used for the binaries.

"Instead, you could include the SRPM for the real kernel package on the
CD. "

the src.rpm IS included on the cds.... not the first 3 CD's but it is
included.
Comment 2 Ed Avis 2004-05-31 08:13:42 EDT
Duh.  I did have a feeling I ought to double-check the kernel-source
package after posting this report, but you beat me to it :-P.  I'd
suggest changing the unpack location to /usr/src/linux-5.6.7-fc2 or
something to make it extra-explicit.

I still think that the SRPM would be a slightly better use of space
than kernel-source.  If you want to include source code on the first
four (binary) CDs, it might as well be in the form of real source
packages.
Comment 3 Arjan van de Ven 2004-08-05 09:20:47 EDT
While I agree with this, other people seem to be quite vocal about not
wanting this on the fedora-devel-list@redhat.com list :(

Note You need to log in before you can comment on or make changes to this bug.