Bug 1248530 - openjdk causes a full desktop crash on RHEL 6 i586
openjdk causes a full desktop crash on RHEL 6 i586
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.7.0-openjdk (Show other bugs)
6.7
i586 Linux
medium Severity urgent
: rc
: ---
Assigned To: Andrew John Hughes
Lukas Zachar
:
Depends On:
Blocks: 1172231 1271375
  Show dependency treegraph
 
Reported: 2015-07-30 09:05 EDT by Stanislav Baiduzhyi
Modified: 2016-05-10 15:42 EDT (History)
4 users (show)

See Also:
Fixed In Version: java-1.7.0-openjdk-1.7.0.85-2.6.1.4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:42:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Duplicate of the fix attached to icedtea bugzilla. (776 bytes, patch)
2015-07-30 09:29 EDT, Stanislav Baiduzhyi
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Icedtea Bugzilla 2568 None None None Never

  None (edit)
Description Stanislav Baiduzhyi 2015-07-30 09:05:14 EDT
Description of problem:
Changing setting in TCK configuration window 2 times causes gnome to spawn lots of new items in taskbar. Pressing Alt+Tab causes immediate crash of all windows and sometimes full X restart.

Version-Release number of selected component (if applicable):
java-1.7.0-openjdk-1.7.0.85-2.6.1.3.el6_7

How reproducible:
Always.

Steps to Reproduce:
1. Open the TCK UI window.
2. Open the configuration window, change the concurrency value, press done.
3. Open again the configuration window, change the concurrency value again, press done.

Actual results:
Multiple windows are spawned in taskbar, pressing Alt+Tab causes crash, waiting causes crash little later.

Expected results:
Everything should work as with icedtea 2.5.5.

Additional info:

Upstream oracle repo does not have the issue.
Reported to icedtea upstream: http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2568

Patch attached in upstream, duplicating here.
Comment 2 Stanislav Baiduzhyi 2015-07-30 09:29:41 EDT
Created attachment 1057682 [details]
Duplicate of the fix attached to icedtea bugzilla.
Comment 3 Andrew John Hughes 2015-07-30 10:14:06 EDT
This only occurs on i586 RHEL 6, so there's scope for getting that version fixed earlier than the next IcedTea update.
Comment 11 Stanislav Baiduzhyi 2016-03-21 10:07:54 EDT
Verified, issue no longer reproducible with version 1.7.0.95-2.6.4.0.el6_7
Comment 15 errata-xmlrpc 2016-05-10 15:42:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0752.html

Note You need to log in before you can comment on or make changes to this bug.