Bug 1248539 - /var/log/messages is spammed with hosted engine errors on RHEV-H 3.5.4
/var/log/messages is spammed with hosted engine errors on RHEV-H 3.5.4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
3.5.4
x86_64 Linux
unspecified Severity urgent
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Martin Sivák
Artyom
: Regression, Triaged, ZStream
Depends On:
Blocks: 1234906 1252801
  Show dependency treegraph
 
Reported: 2015-07-30 09:16 EDT by Michael Burman
Modified: 2016-03-09 14:49 EST (History)
18 users (show)

See Also:
Fixed In Version: v4.17.2
Doc Type: Bug Fix
Doc Text:
The Red Hat Enterprise Virtualization Hypervisor (RHEV-H) attempted to fetch the Manager virtual machine status even though the self-hosted engine was not configured. This resulted in error lines in the log files. With this update, a check was added to skip the Manager virtual machine status collection if self-hosted engine is not configured.
Story Points: ---
Clone Of:
: 1252801 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:49:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages log (81.92 KB, application/x-gzip)
2015-07-30 09:16 EDT, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44325 master MERGED Support for unconfigured startup handling and API access Never
oVirt gerrit 44354 master MERGED Skip hosted engine stats processing when it is not configured Never
oVirt gerrit 45333 ovirt-3.5 MERGED Skip hosted engine stats processing when it is not configured Never

  None (edit)
Description Michael Burman 2015-07-30 09:16:20 EDT
Created attachment 1057680 [details]
messages log

Description of problem:
/var/log/messages is spammed with hosted engine errors on rhev-h 6.7 (3.5.4)

Jul 30 13:05:13 localhost vdsm vds ERROR failed to retrieve Hosted Engine HA score '[Errno 2] No such file or directory: '/etc/ovirt-hosted-engine/hosted-engine.conf''Is the Hosted Engine setup finished?
Jul 30 13:05:28 localhost vdsm vds ERROR failed to retrieve Hosted Engine HA score '[Errno 2] No such file or directory: '/etc/ovirt-hosted-engine/hosted-engine.conf''Is the Hosted Engine setup finished?

The log is flooded with this errors. 
There was no HE deployment on this server. I think it started after first reboot.

Version-Release number of selected component (if applicable):
vdsm-4.16.23-1.el6ev.x86_64
ovirt-node-3.2.3-14.el6.noarch
Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150728.0.el6ev)
3.5.4-1.2.el6ev
Comment 1 Ying Cui 2015-07-31 04:56:09 EDT
# journalctl |grep hosted
Jul 31 08:20:32 localhost systemd-ovirt-ha-agent[1386]: Configuration by ovirt-hosted-engine-setup is required
Jul 31 08:20:32 localhost systemd-ovirt-ha-agent[1386]: Files: /etc/ovirt-hosted-engine/hosted-engine.conf /etc/ovirt-hosted-engine/vm.conf
Jul 31 08:31:46 dhcp-10-118.nay.redhat.com vdsm[17940]: vdsm vds ERROR failed to retrieve Hosted Engine HA score '[Errno 2] No such file or directory: '/etc/ovirt-hosted-engine/hosted-engine.conf''Is the Hosted Engine setup finished?
Jul 31 08:32:00 dhcp-10-118.nay.redhat.com vdsm[17940]: vdsm vds ERROR failed to retrieve Hosted Engine HA score '[Errno 2] No such file or directory: '/etc/ovirt-hosted-engine/hosted-engine.conf''Is the Hosted Engine setup finished?
Jul 31 08:32:18 dhcp-10-118.nay.redhat.com vdsm[17940]: vdsm vds ERROR failed to retrieve Hosted Engine HA score '[Errno 2] No such file or directory: '/etc/ovirt-hosted-engine/hosted-engine.conf''Is the Hosted Engine setup finished?
... ...

# systemctl status ovirt-ha-agent.service 
ovirt-ha-agent.service - oVirt Hosted Engine High Availability Monitoring Agent
   Loaded: loaded (/usr/lib/systemd/system/ovirt-ha-agent.service; enabled)
   Active: failed (Result: exit-code) since Fri 2015-07-31 08:20:32 UTC; 28min ago

Jul 31 08:20:32 localhost systemd-ovirt-ha-agent[1386]: Configuration by ovirt-hosted-engine-setup is required
Jul 31 08:20:32 localhost systemd-ovirt-ha-agent[1386]: Files: /etc/ovirt-hosted-engine/hosted-engine.conf /etc/ovirt-hosted-engine/vm.conf
Jul 31 08:20:32 localhost systemd[1]: ovirt-ha-agent.service: control process exited, code=exited status=6
Jul 31 08:20:32 localhost systemd[1]: Failed to start oVirt Hosted Engine High Availability Monitoring Agent.
Jul 31 08:20:32 localhost systemd[1]: Unit ovirt-ha-agent.service entered failed state.

# systemctl is-enabled ovirt-ha-agent.service
enabled


Can reproduce this issue on rhevh-7.1 (20150728.1.el7ev) as well.

# rpm -qa ovirt-node vdsm ovirt-hosted-engine-ha
ovirt-hosted-engine-ha-1.2.6-2.el7ev.noarch
vdsm-4.16.23-1.el7ev.x86_64
ovirt-node-3.2.3-14.el7.noarch
Comment 2 Dan Kenigsberg 2015-07-31 09:51:18 EDT
Please fix it in 3.5.4 since this is a regression from 3.5.3 (when we did not have an ever-running ovirt-ha-agent on the node).

A long line every 5 second would inflate our log collection and hide real problems - even for users who do not care about hosted-engine.
Comment 5 Nikolai Sednev 2015-08-16 04:07:21 EDT
Please add exact steps for reproduction of a bug.
Comment 6 Michael Burman 2015-08-16 04:19:20 EDT
Hi Nikolai,

There was no exact steps, 
- just install clean rhev-h 6.7 (3.5.4) latest in rhev-M, without any Hosted-engine involved, verify that log isn't spammed with those errors.
- configure some networks via Setup networks and save, reboot host and verify that log isn't spammed with those error messages. Thanks.
Comment 7 Nikolai Sednev 2015-08-16 08:46:03 EDT
Tested on Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150813.0.el6ev) with ovirt-hosted-engine-setup-1.2.5.3-1.el6ev.noarch                                                        
ovirt-hosted-engine-ha-1.2.6-2.el6ev.noarch packages contained within the image, but not deployed.

I've failed to add the RHEVH6.7 to oVirt Engine Version: 3.6.0-0.0.master.20150730161611.git450758e.el7.centos with the error 




2015-08-16 12:28:24,883 WARN  [org.ovirt.engine.core.vdsbroker.VdsManager] (DefaultQuartzScheduler_Worker-38) [] Failed to refresh VDS , vds = 'alma02.qa.l
ab.tlv.redhat.com' : '00efd746-58ca-42ad-968a-2f752be45f7c', error = 'null', continuing.
2015-08-16 12:28:24,883 ERROR [org.ovirt.engine.core.vdsbroker.VdsManager] (DefaultQuartzScheduler_Worker-38) [] Exception: java.lang.NullPointerException
        at java.util.HashMap.putAll(HashMap.java:614) [rt.jar:1.7.0_85]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder.addHostBondDevices(VdsBrokerObjectsBuilder.java:1869) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder.updateNetworkData(VdsBrokerObjectsBuilder.java:1660) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder.updateVDSDynamicData(VdsBrokerObjectsBuilder.java:819) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.GetCapabilitiesVDSCommand.executeVdsBrokerCommand(GetCapabilitiesVDSCommand.java:17) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerCommand.executeVDSCommand(VdsBrokerCommand.java:110) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.VDSCommandBase.executeCommand(VDSCommandBase.java:65) [vdsbroker.jar:]
        at org.ovirt.engine.core.dal.VdcCommandBase.execute(VdcCommandBase.java:33) [dal.jar:]
        at org.ovirt.engine.core.vdsbroker.ResourceManager.runVdsCommand(ResourceManager.java:467) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.VdsManager.refreshCapabilities(VdsManager.java:634) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.HostMonitoring.refreshVdsRunTimeInfo(HostMonitoring.java:119) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.HostMonitoring.refresh(HostMonitoring.java:84) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.VdsManager.onTimer(VdsManager.java:226) [vdsbroker.jar:]
        at sun.reflect.GeneratedMethodAccessor136.invoke(Unknown Source) [:1.7.0_85]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_85]
        at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_85]
        at org.ovirt.engine.core.utils.timer.JobWrapper.invokeMethod(JobWrapper.java:81) [scheduler.jar:]
        at org.ovirt.engine.core.utils.timer.JobWrapper.execute(JobWrapper.java:52) [scheduler.jar:]
        at org.quartz.core.JobRunShell.run(JobRunShell.java:213) [quartz.jar:]
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:557) [quartz.jar:]


Deployment failed because of the rhevm bridge failed to get created on RHEVH6.7.

I didn't saw any of the errors described within the bug on RHEVH6.7.
Comment 8 Nikolai Sednev 2015-08-23 11:30:46 EDT
Tried to add the RHEVH6.7(20150813.0.el6ev) to latest 3.6 engine (rhevm-3.6.0-0.12.master.el6.noarch) and failed with following errors in engine:


2015-08-23 18:26:25,205 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (VdsDeploy) [56b4057d] Correlation ID: 56b4057d, Call
Stack: null, Custom Event ID: -1, Message: Failed to install Host alma04.qa.lab.tlv.redhat.com. Failed to execute stage 'Misc configuration': 'getpwnam():
name not found: ovirt-vmconsole'.
2015-08-23 18:26:25,215 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (VdsDeploy) [56b4057d] Correlation ID: 56b4057d, Call Stack: null, Custom Event ID: -1, Message: Installing Host alma04.qa.lab.tlv.redhat.com. Stage: Pre-termination.
2015-08-23 18:26:25,235 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (VdsDeploy) [56b4057d] Correlation ID: 56b4057d, Call Stack: null, Custom Event ID: -1, Message: Installing Host alma04.qa.lab.tlv.redhat.com. Retrieving installation logs to: '/var/log/ovirt-engine/host-deploy/ovirt-host-deploy-20150823182625-alma04.qa.lab.tlv.redhat.com-56b4057d.log'.
2015-08-23 18:26:25,493 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (VdsDeploy) [56b4057d] Correlation ID: 56b4057d, Call Stack: null, Custom Event ID: -1, Message: Installing Host alma04.qa.lab.tlv.redhat.com. Stage: Termination.
2015-08-23 18:26:25,524 ERROR [org.ovirt.engine.core.uutils.ssh.SSHDialog] (org.ovirt.thread.pool-7-thread-3) [56b4057d] SSH error running command root@alma04.qa.lab.tlv.redhat.com:'umask 0077; MYTMP="$(TMPDIR="${OVIRT_TMPDIR}" mktemp -d -t ovirt-XXXXXXXXXX)"; trap "chmod -R u+rwX \"${MYTMP}\" > /dev/null 2>&1; rm -fr \"${MYTMP}\" > /dev/null 2>&1" 0; tar --warning=no-timestamp -C "${MYTMP}" -x &&  "${MYTMP}"/ovirt-host-deploy DIALOG/dialect=str:machine DIALOG/customization=bool:True': Command returned failure code 1 during SSH session 'root@alma04.qa.lab.tlv.redhat.com'
2015-08-23 18:26:25,525 ERROR [org.ovirt.engine.core.uutils.ssh.SSHDialog] (org.ovirt.thread.pool-7-thread-3) [56b4057d] Exception: java.io.IOException: Command returned failure code 1 during SSH session 'root@alma04.qa.lab.tlv.redhat.com'
        at org.ovirt.engine.core.uutils.ssh.SSHClient.executeCommand(SSHClient.java:527) [uutils.jar:]
        at org.ovirt.engine.core.uutils.ssh.SSHDialog.executeCommand(SSHDialog.java:312) [uutils.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase.execute(VdsDeployBase.java:567) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.InstallVdsInternalCommand.installHost(InstallVdsInternalCommand.java:180) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.InstallVdsInternalCommand.executeCommand(InstallVdsInternalCommand.java:93) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeWithoutTransaction(CommandBase.java:1211) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeActionInTransactionScope(CommandBase.java:1355) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1979) [bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInSuppressed(TransactionSupport.java:174) [utils.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:116) [utils.jar:]
        at org.ovirt.engine.core.bll.CommandBase.execute(CommandBase.java:1392) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeAction(CommandBase.java:374) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runAction(Backend.java:475) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runActionImpl(Backend.java:457) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runInternalAction(Backend.java:667) [bll.jar:]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.8.0_51]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [rt.jar:1.8.0_51]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_51]
        at java.lang.reflect.Method.invoke(Method.java:497) [rt.jar:1.8.0_51]
        at org.jboss.as.ee.component.ManagedReferenceMethodInterceptor.processInvocation(ManagedReferenceMethodInterceptor.java:52) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.invocation.WeavedInterceptor.processInvocation(WeavedInterceptor.java:53) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.interceptors.UserInterceptorFactory$1.processInvocation(UserInterceptorFactory.java:63) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.invocation.WeavedInterceptor.processInvocation(WeavedInterceptor.java:53) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.interceptors.UserInterceptorFactory$1.processInvocation(UserInterceptorFactory.java:63) [jboss-as-ee.jar:7.5.3.Final-r
edhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.invocation.InterceptorContext$Invocation.proceed(InterceptorContext.java:374) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.weld.ejb.Jsr299BindingsInterceptor.delegateInterception(Jsr299BindingsInterceptor.java:74) [jboss-as-weld.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.weld.ejb.Jsr299BindingsInterceptor.doMethodInterception(Jsr299BindingsInterceptor.java:84) [jboss-as-weld.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.weld.ejb.Jsr299BindingsInterceptor.processInvocation(Jsr299BindingsInterceptor.java:97) [jboss-as-weld.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.ee.component.interceptors.UserInterceptorFactory$1.processInvocation(UserInterceptorFactory.java:63) [jboss-as-ee.jar:7.5.3.Final-r
edhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.invocation.WeavedInterceptor.processInvocation(WeavedInterceptor.java:53) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.interceptors.UserInterceptorFactory$1.processInvocation(UserInterceptorFactory.java:63) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ejb3.component.invocationmetrics.ExecutionTimeInterceptor.processInvocation(ExecutionTimeInterceptor.java:43) [jboss-as-ejb3.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.weld.ejb.EjbRequestScopeActivationInterceptor.processInvocation(EjbRequestScopeActivationInterceptor.java:93) [jboss-as-weld.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.invocation.InitialInterceptor.processInvocation(InitialInterceptor.java:21) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.invocation.ChainedInterceptor.processInvocation(ChainedInterceptor.java:61) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.interceptors.ComponentDispatcherInterceptor.processInvocation(ComponentDispatcherInterceptor.java:53) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ejb3.component.singleton.SingletonComponentInstanceAssociationInterceptor.processInvocation(SingletonComponentInstanceAssociationInterceptor.java:52) [jboss-as-ejb3.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.invokeInNoTx(CMTTxInterceptor.java:266) [jboss-as-ejb3.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.supports(CMTTxInterceptor.java:377) [jboss-as-ejb3.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.processInvocation(CMTTxInterceptor.java:246) [jboss-as-ejb3.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ejb3.component.interceptors.CurrentInvocationContextInterceptor.processInvocation(CurrentInvocationContextInterceptor.java:41) [jboss-as-ejb3.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ejb3.component.invocationmetrics.WaitTimeInterceptor.processInvocation(WaitTimeInterceptor.java:43) [jboss-as-ejb3.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ejb3.component.interceptors.ShutDownInterceptorFactory$1.processInvocation(ShutDownInterceptorFactory.java:64) [jboss-as-ejb3.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ejb3.component.interceptors.LoggingInterceptor.processInvocation(LoggingInterceptor.java:59) [jboss-as-ejb3.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.NamespaceContextInterceptor.processInvocation(NamespaceContextInterceptor.java:50) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.TCCLInterceptor.processInvocation(TCCLInterceptor.java:45) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.invocation.ChainedInterceptor.processInvocation(ChainedInterceptor.java:61) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.ViewService$View.invoke(ViewService.java:185) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.ee.component.ViewDescription$1.processInvocation(ViewDescription.java:185) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.invocation.ChainedInterceptor.processInvocation(ChainedInterceptor.java:61) [jboss-invocation.jar:1.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.ProxyInvocationHandler.invoke(ProxyInvocationHandler.java:73) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
        at org.ovirt.engine.core.bll.interfaces.BackendInternal$$$view3.runInternalAction(Unknown Source) [bll.jar:]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.8.0_51]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [rt.jar:1.8.0_51]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_51]
        at java.lang.reflect.Method.invoke(Method.java:497) [rt.jar:1.8.0_51]
        at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:267) [weld-core.jar:1.1.30.Final-redhat-1]
        at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:52) [weld-core.jar:1.1.30.Final-redhat-1]
        at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:137) [weld-core.jar:1.1.30.Final-redhat-1]
        at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:263) [weld-core.jar:1.1.30.Final-redhat-1]
        at org.jboss.weld.bean.proxy.EnterpriseBeanProxyMethodHandler.invoke(EnterpriseBeanProxyMethodHandler.java:115) [weld-core.jar:1.1.30.Final-redhat-1]
        at org.jboss.weld.bean.proxy.EnterpriseTargetBeanInstance.invoke(EnterpriseTargetBeanInstance.java:56) [weld-core.jar:1.1.30.Final-redhat-1]
        at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:105) [weld-core.jar:1.1.30.Final-redhat-1]
        at org.ovirt.engine.core.bll.BackendCommandObjectsHandler$BackendInternal$BackendLocal$142795634$Proxy$_$$_Weld$Proxy$.runInternalAction(BackendCommandObjectsHandler$BackendInternal$BackendLocal$142795634$Proxy$_$$_Weld$Proxy$.java) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.runInternalAction(CommandBase.java:2342) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.AddVdsCommand.access$800(AddVdsCommand.java:67) [bll.jar:]
        at org.ovirt.engine.core.bll.hostdeploy.AddVdsCommand$3.run(AddVdsCommand.java:196) [bll.jar:]
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:92) [utils.jar:]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [rt.jar:1.8.0_51]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [rt.jar:1.8.0_51]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_51]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_51]
        at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_51]
Comment 9 Nikolai Sednev 2015-08-23 11:32:48 EDT
Tried adding the RHEVH6.7 (20150813.0.el6ev) in to the 3.5.4(vt16.7) and also failed.
Comment 12 Nikolai Sednev 2015-08-25 13:01:40 EDT
Had not found any of descrived logs above, tried to add RHEVH6.7 to latest RHEVM3.5 and failed with another errors:
Aug 25 10:55:40 alma03 dhclient[17951]: DHCPREQUEST on p1p1 to 255.255.255.255 port 67 (xid=0x722956c)
Aug 25 10:55:40 alma03 dhclient[17951]: DHCPACK from 10.35.64.1 (xid=0x722956c)
Aug 25 10:55:42 alma03 NET[18006]: /sbin/dhclient-script : updated /etc/resolv.conf
Aug 25 10:55:42 alma03 dhclient[17951]: bound to 10.35.117.24 -- renewal in 33562 seconds.
Aug 25 10:55:42 alma03 vdsm vds ERROR connectivity check failed#012Traceback (most recent call last):#012  File "/usr/share/vdsm/API.py", line 1510, in _rollback#012  File "/usr/share/vdsm/API.py", line 1398, in setupNetworks#012  File "/usr/share/vdsm/supervdsm.py", line 50, in __call__#012  File "/usr/share/vdsm/supervdsm.py", line 48, in <lambda>#012  File "<string>", line 2, in setupNetworks#012  File "/usr/lib64/python2.6/multiprocessing/managers.py", line 740, in _callmethod#012ConfigNetworkError: (10, 'connectivity check failed')
Aug 25 10:55:44 alma03 ntpd[14336]: Listen normally on 8 p1p1 10.35.117.24 UDP 123
Aug 25 10:55:45 alma03 ntpd[14336]: 0.0.0.0 0628 08 no_sys_peer


Engine received:
	
2015-Aug-25, 13:56
	
Host alma03.qa.lab.tlv.redhat.com installation failed. Failed to configure management network on the host.
	
2015-Aug-25, 13:56
	
Failed to configure management network on host alma03.qa.lab.tlv.redhat.com due to setup networks failure.

Tested on host:
Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150813.0.el6ev)

Engine:
rhevm-3.5.4.2-1.3.el6ev.noarch
Comment 13 Nikolai Sednev 2015-08-27 09:01:20 EDT
Tried to separate the issue and to check if appears on RHEL7.2.
Not reproduced on rhevm-3.6.0-0.12.master.el6.noarch RHEL7.2.
This does not reproduced on RHELs.
Comment 14 Nikolai Sednev 2015-08-31 12:07:58 EDT
Failed to add RHEVH3.6 (20150828.0.el6ev) to the rhevm-3.6.0-0.12.master.el6.noarch host cluster with 3.5 compatibility mode. Got "Command returned failure code 1 during SSH session" error.
I'll open separate bug on this, but for now reproduction for this bug is blocked.
Comment 15 Nikolai Sednev 2015-08-31 12:09:05 EDT
Meant RHEVH6.7 (20150828.0.el6ev)
Comment 16 Artyom 2015-09-02 07:19:15 EDT
Verified on vdsm-4.17.3-1.el7ev.noarch no any error message in vdsm or messages log
Comment 18 Artyom 2015-09-16 04:56:27 EDT
This bug opened for version 3.6 of vdsm, bug related to 3.5 still not passed verification, please check:
https://bugzilla.redhat.com/show_bug.cgi?id=1252801
Comment 20 errata-xmlrpc 2016-03-09 14:49:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0422.html

Note You need to log in before you can comment on or make changes to this bug.