Bug 1248546 - initial-setup rhsm_gui screen is not as pretty as it should be.
initial-setup rhsm_gui screen is not as pretty as it should be.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Sefler
John Sefler
Lenka Spackova
:
Depends On:
Blocks: 1246123 1246125
  Show dependency treegraph
 
Reported: 2015-07-30 09:32 EDT by Adrian Likins
Modified: 2015-11-19 06:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Dialogs incorrectly displayed in initial-setup and subscription-manager-gui Certain common dialogs are reused in both the initial-setup utility and in the Subscription Manager GUI. Consequently, some widgets in dialogs are not properly scaled and the text is displayed incorrectly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Registration with Red Hat Subscription Management is Done! (24.20 KB, image/png)
2015-08-26 16:27 EDT, John Sefler
no flags Details

  None (edit)
Description Adrian Likins 2015-07-30 09:32:06 EDT
Description of problem:


The register screen in initial-setup (rhsm_gui) and the register 
dialog code from registergui.py and registration.ui has some warts
and blemishes that need to be corrected. Various widget packing and
fill parameters, etc.


Actual results:
It looks kind of weird.


Expected results:
It should look slightly less weird.

Additional info:
The aesthetics of the dialog will be improved until dev and qa agree it's good enough. Or we run out of time.
Comment 1 Adrian Likins 2015-07-30 09:56:47 EDT
pr at https://github.com/candlepin/subscription-manager/pull/1237
Comment 2 Chris Rog 2015-07-31 15:38:37 EDT
commit e2fbfa9c8ea4289b2cee10607b98acb8dd3aa386
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu Jul 30 09:47:36 2015 -0400

    1248546: Refine the aesthics of register dialog.
    
    This is mostly widget fill and expand options, so the
    widgets adjust to the dialog more uniformly.
Comment 3 Chris Rog 2015-07-31 15:54:56 EDT
commit 3e08248d872deaa63795884ec89c60ed90053d02
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed Jul 29 18:49:57 2015 -0400

    1248546: Slightly better looking done screen.
Comment 5 John Sefler 2015-08-26 16:27:22 EDT
Created attachment 1067396 [details]
Registration with Red Hat Subscription Management is Done!

[root@jsefler-7 ~]# rpm -q subscription-manager-initial-setup-addon
subscription-manager-initial-setup-addon-1.15.9-7.el7.x86_64


Attached a screenshot of the slightly improved done screen from initial-setup.
VERIFIED: the Cancel/Next buttons have been removed. (but are still present in the subscription-manager-gui)
VERIFIED: feedback "Registration with Red Hat Subscription Management is Done!" has been given.

VERIFIED: the widget layout appears to fill the panels of initial-setup.

Moving to VERIFIED.
Comment 6 errata-xmlrpc 2015-11-19 06:50:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.