Bug 1248664 - gui shows warnings to console: Gtk-WARNING **: No object called: 0 0 1 0.10000000000000001 0.90000000000000002 1
gui shows warnings to console: Gtk-WARNING **: No object called: 0 0 1 0.1000...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
: 1248659 (view as bug list)
Depends On:
Blocks: 1246123
  Show dependency treegraph
 
Reported: 2015-07-30 10:29 EDT by Adrian Likins
Modified: 2015-11-19 06:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Likins 2015-07-30 10:29:57 EDT
Description of problem:
On startup, the gui logs several warnings:

(subscription-manager-gui:28289): Gtk-WARNING **: No object called: 0 0 1 0.10000000000000001 0.90000000000000002 1

(subscription-manager-gui:28289): Gtk-WARNING **: No object called: 0 0 396 39.600000000000001 356.40000000000003 396

(subscription-manager-gui:28289): Gtk-WARNING **: No object called: 37 0 116 7.9000000000000004 71.100000000000009 79

(subscription-manager-gui:28289): Gtk-WARNING **: No object called: 0 0 206 20.600000000000001 185.40000000000001 206

(subscription-manager-gui:28289): Gtk-WARNING **: No object called: 0 0 1 0.10000000000000001 0.90000000000000002 1


Version-Release number of selected component (if applicable):
1.15.7ish


Steps to Reproduce:
1. Run 'subscription-manager-gui' from a console


Actual results:
Warnings and errors.


Expected results:
Witty and enthusiastic complements of the developer.
Comment 1 Adrian Likins 2015-07-30 10:31:05 EDT
Those numbers are matches to values in the ui files, so likely a ui xml error introduced with one of the automated glade->ui conversion tools.
Comment 2 Adrian Likins 2015-07-30 16:36:00 EDT
*** Bug 1248659 has been marked as a duplicate of this bug. ***
Comment 3 Adrian Likins 2015-07-30 18:33:00 EDT
pr at https://github.com/candlepin/subscription-manager/pull/1246
Comment 4 Chris Rog 2015-07-31 15:58:21 EDT
commit e0e1035d1aabc53b9e76eb506a46437fb58a43c8
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu Jul 30 16:36:34 2015 -0400

    1248664: Fix GtkAdjustment related warnings
    
    Old gtk/glade used a string value for hadjustment/vadjustment attributes
    for widgets, but newer versions want a GtkAdjustment object name
    instead, so update these ui definations to do that.
    
    This eliminates warnings like:
    (subscription-manager-gui:28289): Gtk-WARNING **: No object called: 0 0
    396 39.600000000000001 356.40000000000003 396
Comment 6 Shwetha Kallesh 2015-08-14 05:34:21 EDT
Marking verified as there are no warnings

[root@dhcp35-236 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.4-1
subscription management rules: 5.15
subscription-manager: 1.15.9-4.el7
python-rhsm: 1.15.4-2.el7


[root@dhcp35-236 ~]# subscription-manager-gui

** (subscription-manager-gui:6243): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-QI50sHmqBJ: Connection refused
Comment 7 errata-xmlrpc 2015-11-19 06:50:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.