Bug 1248674 - Wrong DC/Cluster is show in "New host" dialog
Wrong DC/Cluster is show in "New host" dialog
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.6.0
Assigned To: Alexander Wels
Karolína Hajná
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 10:57 EDT by Yevgeny Zaspitsky
Modified: 2016-05-19 21:23 EDT (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:37:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45682 master MERGED webadmin: new host prefilter dc. Never
oVirt gerrit 45871 ovirt-engine-3.6 MERGED webadmin: new host prefilter dc. Never

  None (edit)
Description Yevgeny Zaspitsky 2015-07-30 10:57:25 EDT
Description of problem:
Same default DC/Cluser is being shown in the DC field of "New Host" dialog despite of selecting of a specific DC in the system tree.

Version-Release number of selected component (if applicable):
ovirt-engine 3.6 (master)

How reproducible:
100%

Steps to Reproduce:
1. Create multiple DCs
2. Select on of the DCs in the system tree panel
3. Select Hosts tab and click on "New Host"
4. Return on steps 2,3 for different DCs

Actual results:
For any DC selection in the system tree, the same default DC/Cluster being shown in the "New Host" dialog.
 
Expected results:
Once a DC is selected in the system tree the DC/Cluster field should show that and should be disabled for change.

Additional info:
Comment 1 Alexander Wels 2015-09-02 14:04:14 EDT
Due to the new combobox we can't disable it when selecting a data center. Since a datacenter can have multiple clusters, we need to allow the user to select the cluster (which is what the combo box does in essence). I have created a patch that filters the available clusters/datacenters to the selected one.
Comment 2 Karolína Hajná 2015-09-14 03:19:09 EDT
Verified on 3.6.0-12
Comment 3 Sandro Bonazzola 2015-11-04 06:37:24 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.