Bug 1248684 - RFE: add exclude and cost properties to dnf.repo.Repo API
RFE: add exclude and cost properties to dnf.repo.Repo API
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Documentation, EasyFix, FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 11:27 EDT by David Shea
Modified: 2017-05-05 09:34 EDT (History)
7 users (show)

See Also:
Fixed In Version: dnf-2.4.0-1.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-05 09:34:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Shea 2015-07-30 11:27:49 EDT
Description of problem:
yum supported repo-level exclude and cost options, which are not in dnf. There is a global exclude option, but not one to exclude packages from an individual repo.

It looks like cost is already there, but not in the API.
Comment 1 David Shea 2015-07-30 11:37:48 EDT
Never mind, I see now that exclude is there by way of the superclass, dnf.yum.conf.RepoConf. So, can these be added to the API for the dnf.repo.Repo? Same for enablegroups and include. Thanks.
Comment 2 Honza Silhan 2015-08-11 08:09:44 EDT
Yes, we can add it to API.
Comment 3 Fedora Admin XMLRPC Client 2016-07-08 05:26:32 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Jaroslav Mracek 2017-04-20 13:19:16 EDT
I created PR with requested changes in documentation https://github.com/rpm-software-management/dnf/pull/791.
Comment 5 Fedora Update System 2017-05-02 11:40:14 EDT
dnf-plugins-core-2.0.0-1.fc26 libdnf-0.8.2-1.fc26 dnf-2.4.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e95959f0d
Comment 6 Fedora Update System 2017-05-04 05:48:25 EDT
dnf-2.4.0-1.fc26 dnf-plugins-core-2.0.0-1.fc26 dnf-plugins-extras-2.0.0-1.fc26 libdnf-0.8.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e95959f0d
Comment 7 Fedora Update System 2017-05-04 18:04:47 EDT
dnf-2.4.0-1.fc26, dnf-plugins-core-2.0.0-1.fc26, dnf-plugins-extras-2.0.0-1.fc26, libdnf-0.8.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e95959f0d
Comment 8 Fedora Update System 2017-05-05 09:34:22 EDT
dnf-2.4.0-1.fc26, dnf-plugins-core-2.0.0-1.fc26, dnf-plugins-extras-2.0.0-1.fc26, libdnf-0.8.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.