Bug 124870 - spamd: -a no longer exists
spamd: -a no longer exists
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks: 123710
  Show dependency treegraph
 
Reported: 2004-05-31 15:27 EDT by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-01 05:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2004-05-31 15:27:48 EDT
The -a option to spamd no longer exists and should be removed from
spamassassin.sysconfig.  See /var/log/messages when (re)starting
spamassassin.
Comment 1 Warren Togami 2004-05-31 18:22:42 EDT
# -a and --auto-whitelist options were removed from 3.0.0
# prevent service startup failure
perl -p -i -e 's/ -a//' /etc/sysconfig/spamassassin
perl -p -i -e 's/ --auto-whitelist//' /etc/sysconfig/spamassassin

I added this to %post in CVS last night, but rebuild failed due to a
build system problem.  Would you consider this to be acceptable?
Comment 2 Ville Skyttä 2004-05-31 19:05:38 EDT
Ah, ok, apparently I was working with an older version
(spamassassin-3.0-0.0.svn20040524).

I guess the above would work for 95% cases.  It would fail in the case
of bundled options though, like " -dac", and would actually break the
config in some cases (eg. " -adc").  Coming up with regexps that would
work for all cases might get butt-ugly, like replacing the first one
with something like (still not perfect):

 's/(["\s]-\w+)a/$1/ ; s/(["\s]-)a(\w+)/$1$2/ ; s/(["\s])-a\b/$1/'

But anyway the "-a" should be removed from the "vanilla"
spamassassin.sysconfig as distributed with the 3.0 rpm unless already
done.
Comment 3 Warren Togami 2004-06-01 04:50:29 EDT
checked in... still waiting on build system

Note You need to log in before you can comment on or make changes to this bug.