Bug 1248711 - rhel-osp-director: UI: unable to change the public interface under service configuration.
rhel-osp-director: UI: unable to change the public interface under service co...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: async
: Director
Assigned To: Brad P. Crochet
Alexander Chuzhoy
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 12:26 EDT by Alexander Chuzhoy
Modified: 2015-08-13 16:04 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-tuskar-ui-0.3.0-14.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 16:04:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 207586 None None None Never

  None (edit)
Description Alexander Chuzhoy 2015-07-30 12:26:26 EDT
rhel-osp-director: UI: unable to change the public interface under service configuration.


Environment:



Steps to reproduce:
1. Deploy undercloud on bare metal.
2. Go to the "service configuration" tab, select "global", and click on the "Simplified configuration" button. 
3. Try to change the "Public interface" value.


Result:
The public interface for BM is limited to em2. 
Unable to change it to another interface:
1. "Simplified configuration" allows to select between em2(bare metal) and eth0(virtual)
2. "Advanced configuration" allows to set the "Neutron Public Interface" field to any nic name, but after clicking on "Save" and checking the value again - it goes back to em2.

Expected result:
Should be able to specify any NIC.
Comment 3 chris alfonso 2015-07-30 13:42:34 EDT
Brad, can you verify that we can't set the value to anything but eth0 or em2 so that we can assess whether this needs to be a 0 day fix?
Comment 4 Brad P. Crochet 2015-07-30 15:32:40 EDT
The problem lies in the advanced configuration. The simple configuration does indeed only allow eth0 or em2, but a user *should* be able to specify something different in the advanced configuration.

There is a problem where the code for the advanced configuration syncs the params across role types. Therefore, it was setting it to whatever is in one of the roles. 

The current proposed fix just disables that syncing. There should be a future enhancement to perhaps use a white or blacklist for syncing.
Comment 6 Alexander Chuzhoy 2015-08-10 14:11:43 EDT
Environment:
openstack-tuskar-ui-0.3.0-15.el7ost.noarch
instack-undercloud-2.1.2-23.el7ost.noarch

Using the "Simplified configuration" it still lets only select between eth0 and em2.

Using the "Advanced configuration", the NIC set in the "Neutron Public Interface" field is saved now (i.e. not lost), after clicking on "Save Configuration".
Comment 7 Alexander Chuzhoy 2015-08-11 12:35:55 EDT
Verified:  It's possible to set the Neutron Public Interface via "Advanced Configuration".

Environment:
python-tuskarclient-0.1.18-3.el7ost.noarch
openstack-tuskar-ui-extras-0.0.4-1.el7ost.noarch
instack-undercloud-2.1.2-23.el7ost.noarch
openstack-tuskar-0.4.18-3.el7ost.noarch
openstack-tuskar-ui-0.3.0-15.el7ost.noarch


Filed this non-blocker for the "Simplified Configuraton" instead:
https://bugzilla.redhat.com/show_bug.cgi?id=1252553


Thanks.
Comment 9 errata-xmlrpc 2015-08-13 16:04:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1624

Note You need to log in before you can comment on or make changes to this bug.