Bug 1248713 - Client has Software Updates Available but when spacewalk goes to install it does nothing.
Client has Software Updates Available but when spacewalk goes to install it d...
Status: CLOSED DUPLICATE of bug 1292288
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
2.3
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jiří Dostál
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2015-07-30 12:28 EDT by Mike
Modified: 2017-09-28 14:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-10 12:51:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System History after executing update. (132.91 KB, image/png)
2015-07-30 12:28 EDT, Mike
no flags Details

  None (edit)
Description Mike 2015-07-30 12:28:58 EDT
Created attachment 1057739 [details]
System History after executing update.

I am trying to make sure all of my client servers are up-to-date.  When I try to initiate an update for software it executes, but returns "Requested packages already installed" (code 0).  Why does it say this, but then once returned to server list it still shows Critial/Non-Critical/Packages available for update. 


How reproducible:

Go back to Systems->(click client)->(click "Critical")->Select ALL->Apply Errata->Confirm


Actual results:
(screenshot)

Expected results:
No more updates available.

Additional info:

Note: I do have OSAD installed.  I can however run a remote command with no issues through spacewalk.
Comment 1 Kevin Stange 2015-11-30 12:39:15 EST
I started having this issue with CentOS 5-based systems only after updating to Spacewalk 2.4.  The packages never get installed as the rhn_check process tells the spacewalk server that the package updates are not needed.

It appears to be an issue with the agent on those CentOS 5 servers.
Comment 2 Kevin Stange 2015-11-30 14:30:47 EST
Output of rhn_check, rpm -q, yum check-update showing that it believes the package is up to date while yum does not agree:

[root@X ~]# rhn_check -vvvv
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: check_action{'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>packages.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><array><data>\n<value><string>kernel-headers</string></value>\n<value><string>2.6.18</string></value>\n<value><string>407.el5</string></value>\n<value><string></string></value>\n<value><string>x86_64</string></value>\n</data></array></value>\n<value><array><data>\n<value><string>kernel</string></value>\n<value><string>2.6.18</string></value>\n<value><string>407.el5</string></value>\n<value><string></string></value>\n<value><string>x86_64</string></value>\n</data></array></value>\n<value><array><data>\n<value><string>kernel-devel</string></value>\n<value><string>2.6.18</string></value>\n<value><string>407.el5</string></value>\n<value><string></string></value>\n<value><string>x86_64</string></value>\n</data></array></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 110069}
updateLoginInfo() login info
D: login(forceUpdate=True) invoked
logging into up2date server
D: rpcServer: Calling XMLRPC up2date.login
D: writeCachedLogin() invoked
D: Wrote pickled loginInfo at 1448911580.15 with expiration of 1448915180.15 seconds.
successfully retrieved authentication token from up2date server
D: logininfo:{'X-RHN-Server-Id': 1000010013, 'X-RHN-Auth-Server-Time': '1448911580.12', 'X-RHN-Auth': 'XXX', 'X-RHN-Auth-Channels': [['centos5-x86_64', '20151130114902', '1', '1'], ['centos5-x86_64-cr', '20151130115326', '0', '1'], ['steadfast-centos5-x86_64', '20151130125647', '0', '1'], ['centos5-x86_64-contrib', '20151130115326', '0', '1'], ['centos5-x86_64-extras', '20151130115327', '0', '1'], ['centos5-x86_64-updates', '20151130115348', '0', '1'], ['epel5-centos5-x86_64', '20151130122533', '0', '1'], ['centos5-x86_64-addons', '20151130115325', '0', '1'], ['kernelcare-centos5-x86_64', '20151130125759', '0', '1'], ['idera-sb-centos5-x86_64', '20151130125726', '0', '1'], ['spacewalk-latest-client-centos5-x86_64', '20151130125637', '0', '1']], 'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action{'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>packages.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><array><data>\n<value><string>kernel-headers</string></value>\n<value><string>2.6.18</string></value>\n<value><string>407.el5</string></value>\n<value><string></string></value>\n<value><string>x86_64</string></value>\n</data></array></value>\n<value><array><data>\n<value><string>kernel</string></value>\n<value><string>2.6.18</string></value>\n<value><string>407.el5</string></value>\n<value><string></string></value>\n<value><string>x86_64</string></value>\n</data></array></value>\n<value><array><data>\n<value><string>kernel-devel</string></value>\n<value><string>2.6.18</string></value>\n<value><string>407.el5</string></value>\n<value><string></string></value>\n<value><string>x86_64</string></value>\n</data></array></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 110069}
D: handle_action actionid = 110069, version = 2
D: do_call packages.update([['kernel-headers', '2.6.18', '407.el5', '', 'x86_64'], ['kernel', '2.6.18', '407.el5', '', 'x86_64'], ['kernel-devel', '2.6.18', '407.el5', '', 'x86_64']],){'cache_only': None}
Loaded plugins: fastestmirror, rhnplugin
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))
Config time: 0.374
D: rpcServer: Calling XMLRPC up2date.listChannels
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Package Sacks
Loading mirror speeds from cached hostfile
pkgsack time: 1.615
rpmdb time: 0.000
Loading mirror speeds from cached hostfile
repo time: 0.004
D: Called update[['kernel-headers', '2.6.18', '407.el5', '', 'x86_64'], ['kernel', '2.6.18', '407.el5', '', 'x86_64'], ['kernel-devel', '2.6.18', '407.el5', '', 'x86_64']]
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D:  read h#    1964 Header sanity check: OK
D: More recent version of package kernel-headers-0:2.6.18-407.el5.x86_64 is already installed
D:  read h#    1782 Header sanity check: OK
D:  read h#    1929 Header sanity check: OK
D:  read h#    1963 Header sanity check: OK
D: More recent version of package kernel-0:2.6.18-407.el5.x86_64 is already installed
D:  read h#    1780 Header sanity check: OK
D:  read h#    1932 Header sanity check: OK
D:  read h#    1965 Header sanity check: OK
D: More recent version of package kernel-devel-0:2.6.18-407.el5.x86_64 is already installed
D: Sending back response(0, 'Requested packages already installed', {})
D: do_call packages.checkNeedUpdate('rhnsd=1',){}
D: local action status: (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: rpcServer: Calling XMLRPC registration.welcome_message
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
[root@X ~]# rpm -q kernel kernel-devel
kernel-2.6.18-371.11.1.el5
kernel-2.6.18-404.el5
kernel-2.6.18-406.el5
kernel-devel-2.6.18-371.11.1.el5
kernel-devel-2.6.18-404.el5
kernel-devel-2.6.18-406.el5
[root@X ~]# yum check-update
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Loading mirror speeds from cached hostfile

kernel.x86_64                          2.6.18-407.el5    centos5-x86_64-updates 
kernel-devel.x86_64                    2.6.18-407.el5    centos5-x86_64-updates 
kernel-headers.x86_64                  2.6.18-407.el5    centos5-x86_64-updates
Comment 3 dyioulos 2016-02-15 12:55:01 EST
I'm having the same issue with all package updates to CentOS 5, CentOS 5 x86, and 6 x86 client I try to do from the Spacewalk UI. The details are the same as those of the OP, but here's the output of rhn_check -vvvv run against a CentOS 5 client:

[root@eou1 ~]# /usr/sbin/rhn_check -vvvv
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: do_call packages.checkNeedUpdate('rhnsd=1',){}
Loaded plugins: fastestmirror, rhnplugin
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))
Config time: 0.080
D: login(forceUpdate=False) invoked
D: readCachedLogin invoked
D: Checking pickled loginInfo, currentTime=1455558512.77, createTime=1455551151.65, expire-offset=3600.0
D: Pickled loginInfo has expired, created = 1455551151.65, expire = 1455554751.65.
logging into up2date server
D: rpcServer: Calling XMLRPC up2date.login
D: writeCachedLogin() invoked
D: Wrote pickled loginInfo at 1455558512.79 with expiration of 1455562112.79 seconds.
successfully retrieved authentication token from up2date server
D: logininfo:{'X-RHN-Server-Id': 1000010149, 'X-RHN-Auth-Server-Time': '1455558513.45', 'X-RHN-Auth': '8AgNyqCQZ0tyBaS8agH0f/L6qkbZdmwaMYnLd9nSWGE=', 'X-RHN-Auth-Channels': [['centos5-i386', '20150219163504', '1', '1'], ['rpmforge-el5-i386', '20160213003303', '0', '1'], ['puppet-el5-i386', '20160213001620', '0', '1'], ['spacewalk-client-el5-i386', '20160210110000', '0', '1'], ['centos5-updates-i386', '20160213003518', '0', '1'], ['centos5-base-i386', '20160210040000', '0', '1'], ['epel5-i386', '20160213003720', '0', '1']], 'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: rpcServer: Calling XMLRPC up2date.listChannels
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Package Sacks
Loading mirror speeds from cached hostfile
 * base: mirrors.lga7.us.voxel.net
 * centosplus: mirror.trouble-free.net
 * epel: mirror.us.leaseweb.net
 * extras: mirror.us.leaseweb.net
 * updates: mirror.cs.vt.edu
pkgsack time: 1.398
rpmdb time: 0.000
Checking for new repos for mirrors
repo time: 0.001
D: local action status: (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: rpcServer: Calling XMLRPC registration.welcome_message
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))

[root@eou1 ~]# rpm -q|grep tzdata
tzdata-2015g-1.el5

[root@eou1 ~]# rpm check-update
tzdata.i386  2016a-1.el5  centos5-updates-i386

I've tried everything I can think of, and various things I've read, to remediate the problem, but without success.
Comment 4 Jiří Dostál 2016-02-19 10:03:47 EST
Please check latest commit on https://bugzilla.redhat.com/show_bug.cgi?id=1292288.
Comment 5 Jiří Dostál 2016-11-10 12:51:52 EST
Fixed by commit in Bugzilla no. 1292288 - 2dfce30827cc3bde997249dfa318f8d1d0e8f83b

Closing as Duplicate.

*** This bug has been marked as a duplicate of bug 1292288 ***
Comment 6 Eric Herget 2017-09-28 14:11:53 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.