Bug 1248723 - [GSS] Internal RuntimeExceptions in the HotRod server which have impact on the functionality should be logged as ERROR and reported to the client
[GSS] Internal RuntimeExceptions in the HotRod server which have impact on th...
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.4.1
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: 6.6.0
Assigned To: Galder Zamarreño
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 12:57 EDT by wfink
Modified: 2015-10-27 04:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 04:52:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-5651 Major Resolved Internal RuntimeExceptions which have impact on the functionality should be logged as ERROR 2015-12-08 10:12 EST

  None (edit)
Description wfink 2015-07-30 12:57:29 EDT
Description of problem:
If internal issues throw RuntimeException (i.e. like CLassCastException see https://bugzilla.redhat.com/show_bug.cgi?id=1248160) it is very difficult to track this down as the Exception is only visible if the HotRod client! run with activated DEBUG/TRACE level.

How reproducible:
Use reproducer or test for https://bugzilla.redhat.com/show_bug.cgi?id=1248160


Actual results:
Cause only in DEBUG logging of the client side

Expected results:
ERROR log at server side
Comment 3 JBoss JIRA Server 2015-10-27 04:51:50 EDT
Galder Zamarreño <galder.zamarreno@redhat.com> updated the status of jira ISPN-5651 to Resolved
Comment 4 Galder Zamarreño 2015-10-27 04:52:28 EDT
Not a bug.

Note You need to log in before you can comment on or make changes to this bug.