Bug 1248729 - Filter dialog does not come up in a focused state
Filter dialog does not come up in a focused state
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks: 1246123
  Show dependency treegraph
 
Reported: 2015-07-30 13:34 EDT by Sean Toner
Modified: 2015-11-19 06:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows unfocused dialog (411.73 KB, image/png)
2015-07-30 13:34 EDT, Sean Toner
no flags Details
Filter dialogue (131.88 KB, image/png)
2015-08-07 08:10 EDT, Shwetha Kallesh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2122 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2015-11-19 05:31:14 EST

  None (edit)
Description Sean Toner 2015-07-30 13:34:35 EDT
Created attachment 1057766 [details]
Shows unfocused dialog

Description of problem:
=======================

If a user clicks on the Filter button in the All Available Subscriptions tab, the dialog that comes up is not focused.  This may be confusing to a customer as unless they click in the dialog to focus it, the dialog appears disabled


Version-Release number of selected component (if applicable):
=============================================================

[root@rhel7-2-test-stoner ~]# rpm -qa | grep subscription-manager-gui
subscription-manager-gui-1.15.6-1.el7.x86_64


How reproducible:
==================

Always


Steps to Reproduce:
===================

1. Go to All Available Subscriptions Tab
2. Click Filters button

Actual results:
===============

Filter dialog is not focused


Expected results:
=================

Dialog should be focused even without the user first clicking on it


Additional info:
Comment 2 Adrian Likins 2015-07-30 18:36:06 EDT
pr at https://github.com/candlepin/subscription-manager/pull/1248
Comment 3 Chris "Ceiu" Rog 2015-07-31 16:01:24 EDT
commit 8ec19e41989deab6912b131473a91f8d15b822c3
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu Jul 30 18:33:32 2015 -0400

    1248729: All subs filter dialog was not focused.
    
    The window type hint for the filter dialog was previously
    'menu', which causes the window to appear undecorated
    and unfocussed. This changes it to 'dialog' to correct
    that.
Comment 5 Shwetha Kallesh 2015-08-07 08:10:22 EDT
Created attachment 1060346 [details]
Filter dialogue

Marking verified as the dialogue is in filtered state

[root@dhcp35-236 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.4-1
subscription management rules: 5.15
subscription-manager: 1.15.9-3.el7
python-rhsm: 1.15.4-2.el7
Comment 6 errata-xmlrpc 2015-11-19 06:50:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.