Bug 1248730 - rawstudio bundles libraries
rawstudio bundles libraries
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: rawstudio (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gianluca Sforna
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2015-07-30 13:42 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2017-08-09 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 08:03:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2015-07-30 13:42:54 EDT
Description of problem:
rawstudio bundles rawspeed. This is against https://fedoraproject.org/wiki/Packaging:Guidelines#Duplication_of_system_libraries .

Version-Release number of selected component (if applicable):
rawstudio-2.1-0.4.20150511git983bda1.fc23
Comment 1 Dominik 'Rathann' Mierzejewski 2015-07-30 13:49:51 EDT
Actually, more stuff is are bundled apart from rawspeed:
Adobe DNG SDK:
plugins/dcp/adobe-camera-raw-tone.[ch]

Mesa3D code fragment:
plugins/dcp/pow-sse2.h

dcraw:
plugins/load-dcraw/dcraw*
Comment 2 Sergio Monteiro Basto 2015-08-02 21:45:48 EDT
Hi, 
- Adding in CC, Anders Brander, to keep him informed ...

- As I wrote, about rawspeed. First we need to package the rawspeed, let me know if we got any evolution on this matter.  

- Another task, I found it on [1] "While making this change, it seems like a good time to add: 
# See https://fedorahosted.org/fpc/ticket/530#comment:3
Provides: bundled(dcraw)u "


[1]https://bugzilla.redhat.com/show_bug.cgi?id=1221256#c5

Best regards,
Comment 3 Sergio Monteiro Basto 2015-08-02 21:53:14 EDT
Anders Brander has commented on [1] , about unbundling Rawspeed . 


[1] https://github.com/rawstudio/rawstudio/issues/6
Comment 4 Sergio Monteiro Basto 2015-11-26 00:26:27 EST
About dcraw 
in [1] found this: 
Note for Rawstudio developers:
dcraw is copied from UFRaw CVS at:
pserver:anonymous@ufraw.cvs.sourceforge.net:/cvsroot/ufraw
Current revisions:
dcraw.cc [1.258]
dcraw.h [1.71]
dcraw_api.cc [1.78]
dcraw_api.h [1.45]

so plugin load-dcraw [2] have 4 bundle files but the other 3 files aren't ... 

[1] https://github.com/rawstudio/rawstudio/blob/master/plugins/load-dcraw/dcraw.cc

[2] https://github.com/rawstudio/rawstudio/tree/master/
Comment 5 Jan Kurik 2016-02-24 08:29:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Fedora End Of Life 2017-07-25 15:04:05 EDT
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.
Comment 7 Dominik 'Rathann' Mierzejewski 2017-07-25 16:14:24 EDT
I guess this can be closed as WONTFIX now. The required Provides: were added and I guess upstream is still not even thinking about supporting a shared rawspeed.
Comment 8 Fedora End Of Life 2017-08-08 08:03:58 EDT
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 9 Sergio Monteiro Basto 2017-08-09 12:46:51 EDT
(In reply to Dominik 'Rathann' Mierzejewski from comment #7)
> I guess this can be closed as WONTFIX now. The required Provides: were added
> and I guess upstream is still not even thinking about supporting a shared
> rawspeed.

yeah the part of providing a or b is fixed and last time I checked rawspeed has changed a lot and could be that now are a shared library ... 
https://github.com/darktable-org/rawspeed/releases

Note You need to log in before you can comment on or make changes to this bug.