This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1248734 - Certain dialogs should not be so huge in subscription-manager-gui
Certain dialogs should not be so huge in subscription-manager-gui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
high Severity low
: rc
: ---
Assigned To: Adrian Likins
Sean Toner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 13:53 EDT by Sean Toner
Modified: 2015-11-19 06:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the register and auto-attach dialogs size (595.32 KB, application/x-gzip)
2015-07-30 13:53 EDT, Sean Toner
no flags Details
Fixed dialogs (202.04 KB, application/x-gzip)
2015-10-01 11:38 EDT, Sean Toner
no flags Details

  None (edit)
Description Sean Toner 2015-07-30 13:53:24 EDT
Created attachment 1057771 [details]
Screenshot of the register and auto-attach dialogs size

Description of problem:
=======================

Technically this is not a bug, but it looks unpolished.  Some of the dialogs come up disproportionately large with a large portion of the space being empty


Version-Release number of selected component (if applicable):
=============================================================

subscription-manager-gui-1.15.6-1.el7.x86_64


How reproducible:
=================

Always

Steps to Reproduce:
===================

1. Click on the Menu System->Register
2. Look at Register dialog
3. Register the system
4. Go to All Available Subscriptions tab
5. Click on Auto Attach button
6. Observe the Auto attach dialog

Actual results:
===============

See attached screenshots


Expected results:
=================

These dialogs should probably be smaller as the information within the dialog is rather small.


Additional info:
Comment 4 Adrian Likins 2015-09-25 11:40:02 EDT
in github master:

commit d72989505c608a5ad0c443b8e7f03da70b2201ad
Author: Adrian Likins <alikins@redhat.com>
Date:   Tue Sep 8 10:53:19 2015 -0400

    884288: Make register widgets handle resizing.
    
    For wide windows or dialogs, most widgets were set to
    use a align mode of 'fill'. This causes things like entry
    boxes to expand to the entire width of the parent. Combined
    with widget package that was causing the RegisterWidget to
    expand to cover the widgets register screen, many widgets
    fill the entire width of the screen.
    
    Make Entry widgets set a min and max width, but allow them
    to expand and fill up to that max width.
    
    Tweak most of the Labels to auto wrap. Enabling end ellipsing
    on most labels, but also give them plenty of room to expand with
    by setting the suggest number of lines before ellipsing. Labels
    also get set to expand. That combo removes the behavior of
    labels that require a ton of horizontal space, forcing the
    RegisterWidget to be very wide (and causing entries and the
    like to fill all of that space).
    
    Add Gtk.Adjustments for any ScrolledWindows that need it. Remove
    some Gtk.ViewPorts that are not needed (those holding a TreeView
    for example).
    
    Set min size requests for the ScrollWindows, so the defualt size
    allocated doesn't hide the contents.
    
    Replace some Gtk.Box based layouts with Gtk.Grid instead. Especially
    those that need Gtk.Alignment widgets for formatting.
    
    Generally reduce some of the spacing and margins of the widgets,
    especially around the edges of notebook screens. It should be up
    to the parent that holds the RegisterWidget to setup borders, spacing,
    and margins.
    
    Add size groups for some of the more fussier layouts.
Comment 6 Sean Toner 2015-10-01 11:38 EDT
Created attachment 1079193 [details]
Fixed dialogs

Looks good now.  The dialogs are proportioned better, and the progress dialog shows the slider moving now.
Comment 7 errata-xmlrpc 2015-11-19 06:50:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.