Bug 1248746 - The contract selection dialog does not expand correctly
The contract selection dialog does not expand correctly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michael Stead
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 14:12 EDT by Sean Toner
Modified: 2015-11-19 06:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contract dialog screenshot (58.92 KB, image/png)
2015-07-30 14:12 EDT, Sean Toner
no flags Details
contract selection dialogue (109.85 KB, image/png)
2015-08-14 08:41 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Sean Toner 2015-07-30 14:12:50 EDT
Created attachment 1057796 [details]
contract dialog screenshot

Description of problem:
=======================

The table for the contract is very small initially so if a user tries to expand the entire dialog, the table does not grow with the size of the dialog frame.


Version-Release number of selected component (if applicable):
=============================================================

subscription-manager-gui-1.15.6-1.el7.x86_64

How reproducible:
=================

Always

Steps to Reproduce:
===================

1. Register a system
2. Select All Available Subscriptions
3. Click Update
4. Select a subscription that has multiple contracts associated with it
5. Click Attach
6. Resize the contract dialog vertically (it scales ok horizontally)
7. Observe that initially the table is too small also

Actual results:
===============

See attached screenshot


Expected results:
=================

The table should either be big enough to view all rows in the table, or there should be a way for the user to resize and expand the dialog to make it viewable.

Additional info:
Comment 3 Michael Stead 2015-07-31 15:21:40 EDT
Fix now in master branch.
Comment 4 Chris Rog 2015-07-31 16:04:33 EDT
commit c5126d4d94558b847fe070b6a58b04be508a2cba
Author: Michael Stead <mstead@redhat.com>
Date:   Fri Jul 31 12:57:13 2015 -0300

    1248746: Fix layout of contract dialog (GTK3)
Comment 6 Shwetha Kallesh 2015-08-14 08:41:55 EDT
Created attachment 1063011 [details]
contract selection dialogue

Marking verified!

[root@dhcp35-236 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.6-1
subscription management rules: 5.16
subscription-manager: 1.15.9-4.el7
python-rhsm: 1.15.4-2.el7
[root@dhcp35-236 ~]# rpm -qa | grep gui
subscription-manager-gui-1.15.9-4.el7.x86_64
Comment 7 errata-xmlrpc 2015-11-19 06:50:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.