Bug 1248755 - SELinux is preventing a Brother print from printing
SELinux is preventing a Brother print from printing
Status: CLOSED DUPLICATE of bug 1246898
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 14:30 EDT by Adrián Reboreda Martínez
Modified: 2015-08-21 16:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-21 12:21:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrián Reboreda Martínez 2015-07-30 14:30:02 EDT
Description of problem:
When I try to print with a Brother printer SELinux denies the work. This started after the last update

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-128.6.fc22.noarch

How reproducible:
Print any work with SELinux activated

Steps to Reproduce:
1. Check that selinux is working
# getenforce
Enforcing
2. Print any work from any GUI

Actual results:
There's no print load in system-config-printers, even if the works are no printed

Expected results:
Print works.

Additional info:
If selinux is disabled I can print:
# setenfoce 0

Also using ausearch after trying to print a work returns this:
# ausearch -m avc -ts today
time->Thu Jul 30 13:27:11 2015
type=AVC msg=audit(1438280831.893:596): avc:  denied  { execmem } for  pid=4194 comm="brcupsconfpt1" scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tclass=process permissive=0
----
time->Thu Jul 30 13:27:11 2015
type=AVC msg=audit(1438280831.911:598): avc:  denied  { execmem } for  pid=4208 comm="brmfcj4510dwfil" scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tclass=process permissive=0

Note: I've tried to update selinux-policy-targeted to the updates-testing version to no avail

#rpm -q selinux-policy-targeted
selinux-policy-targeted-3.13.1-128.8.fc22.noarch
Comment 1 Kai Engert (:kaie) 2015-08-21 12:21:55 EDT

*** This bug has been marked as a duplicate of bug 1246898 ***

Note You need to log in before you can comment on or make changes to this bug.