Bug 1248773 - Layout issues on proxy configuration dialog when resized
Layout issues on proxy configuration dialog when resized
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michael Stead
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 15:25 EDT by Michael Stead
Modified: 2015-11-19 06:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Layout Issues (40.75 KB, image/png)
2015-07-30 15:25 EDT, Michael Stead
no flags Details
Proxy dialogue layout (95.43 KB, image/png)
2015-08-06 05:08 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Michael Stead 2015-07-30 15:25:57 EDT
Created attachment 1057828 [details]
Layout Issues

Description of problem:
Layout issues on proxy configuration dialog when resized.

Steps to Reproduce:
1. Load the Proxy configuration dialog (via registration or System->Configure Proxy
2. Make the dailog larger by dragging the bottom edge


Actual results:
Light bulb icon and example proxy string move to the center of the screen.

Expected results:
Extra space should be allocated to the bottom of the dialog on resize.

Additional info:
See attachment for example.
Comment 1 Michael Stead 2015-07-30 15:30:26 EDT
Awaiting code review:
https://github.com/candlepin/subscription-manager/pull/1243
Comment 2 Michael Stead 2015-07-31 15:22:46 EDT
Fix now in master branch.
Comment 3 Chris Rog 2015-07-31 15:49:25 EDT
commit 684b578b08f643cb3e7a10a1639138a86a929b36
Author: Michael Stead <mstead@redhat.com>
Date:   Thu Jul 30 14:01:58 2015 -0300

    1248773: Fixed proxy dialog layout (GTK3)
Comment 5 Shwetha Kallesh 2015-08-06 05:08:32 EDT
Created attachment 1059810 [details]
Proxy dialogue layout

Marking verified as extra space is allocated to the bottom of the dialog when you make it larger by dragging the bottom edge


[root@dhcp35-236 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.4-1
subscription management rules: 5.15
subscription-manager: 1.15.9-3.el7
python-rhsm: 1.15.4-2.el7
Comment 6 errata-xmlrpc 2015-11-19 06:50:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.