Bug 124878 - boot process hangs modprobe:FATAL Error inserting floppy
boot process hangs modprobe:FATAL Error inserting floppy
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-31 19:18 EDT by Bill Rosmus
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:23:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Rosmus 2004-05-31 19:18:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
After installing Fedora Core 2, the system won't boot.  There were no
issues during the install process.

Steps to produce:
1) Turn on computer,
2) Grub menu displays,
3) I select the linux installation, 
4) It starts booting, gets part way through, then hangs.

The error message is:

"modprobe:FATAL Error inserting floppy
(/lib/modules/2.6.5-1.358/kernel/drivers/block/floppy.ko): No such device"

Installed on an HP Pavilion zv5034us laptop Which * Has * No * Floppy
* Drive *.  This is a dual boot with Windows XP.  No problem with XP
after the graphical install process.  Suse 9.0 which was installed
prior to me installing Fedora Core (also dual boot) on the same
computer worked fine (kernel: 2.4).


Version-Release number of selected component (if applicable):
Fedora Core 2

How reproducible:
Always

Steps to Reproduce:
1) Turn on computer,
2) Grub menu displays,
3) I select the linux installation, 
4) It starts booting, gets part way through, then hangs.

Actual Results:  The system would not boot.

Expected Results:  A booted working system.

Additional info:

I didn't have this problem with a Suse Linux installation previously
installed.  I didn't really like the Suse install so wanted to try
Fedora.  Fedora won't run.  I'm willing to see  if you guys can
provide a fix for me before I try another disro.

What can be done to fix this?  Please.
Comment 1 Bill Rosmus 2004-06-02 10:58:29 EDT
Figured out (guessed) how to start in failsafe mode.  Used init level 3.

In the /boot/grub/devices.map (if I remember the filename correctly,
but it is close enough) there were two lines only.  One for a floppy
drive, and one for a hard drive.  I commented out the floppy drive
line and restarted the laptop.  If got to the point with the original
error message and skipped over it fine.

However, when it got to the point where the X server was starting, it
froze up again.  You could see the typical multicoloured hash type of
patterns across the top of the screen that you see just before the X
server kicks in, and then the screen went blank and that was it... dead.

Like I said, this laptop worked fine with Suse 9.0 (minus sound which
would not work, which is why I am wanting to change to another
distro), so I don't think it is a problem with the machine's video. 
Rather, I think it is a problem with the Fedora code or configuration.
Just stating the obvious.  I would like to see Fedora work on this
machine/laptop.
Comment 2 Dave Jones 2005-04-16 01:23:28 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.