Bug 1248783 - kdbus: dbus activation of org.fedoraproject.rolekit1.service failed
kdbus: dbus activation of org.fedoraproject.rolekit1.service failed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 15:57 EDT by Stephen Gallagher
Modified: 2015-08-06 22:07 EDT (History)
9 users (show)

See Also:
Fixed In Version: systemd-224-1.fc24.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 22:07:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2015-07-30 15:57:55 EDT
Description of problem:
I spun up a Fedora Server 23 Alpha TC2 system and installed the
Rawhide kernel, then rebooted with kdbus=1

I then tried to run 'rolectl list roles', which returned "Rolekit is
not running". So it failed to provide D-BUS activation functionality,
which is problematic.

When I manually ran the service, D-BUS communication between the client
and the daemon seems to be working properly.


Version-Release number of selected component (if applicable):
kernel-4.2.0-0.rc4.git2.1.fc24.x86_64
systemd-222-1.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Boot the above kernel with kdbus=1 on the kernel boot prompt
2. Run 'rolectl list roles' as root on the system

Actual results:
"Rolekit is not running"

Expected results:
Rolekit should be dbus-activated and return the list of available roles for deployment.

Additional info:
There's nothing particularly special about rolekit's d-bus activation, it's just a convenient test because it's part of the standard Fedora Server install and has a simple CLI that uses the API.
Comment 1 Jóhann B. Guðmundsson 2015-07-30 16:11:47 EDT
rolectl source 
https://git.fedorahosted.org/cgit/rolekit.git/tree/src/rolectl
Comment 2 Stephen Gallagher 2015-07-30 16:19:34 EDT
(In reply to Jóhann B. Guðmundsson from comment #1)
> rolectl source 
> https://git.fedorahosted.org/cgit/rolekit.git/tree/src/rolectl

Actually, we recently moved the upstream sources to https://github.com/libre-server/rolekit/blob/master/src/rolectl. I need to close out the fedorahosted one. Thanks for the link, though, Jóhann. That probably would be useful info for the BZ.
Comment 3 David Herrmann 2015-07-31 05:34:17 EDT
Indeed. This is a fallout from the forced broadcast-filtering in bus-proxy (added in systemd-223 [1]). Patches pending on github [2]. With [2] applied, everything works fine for me now.

Thanks for the report! Once reviewed, the fixes will go to Rawhide.

[1] https://github.com/systemd/systemd/pull/606
[2] https://github.com/systemd/systemd/pull/800
Comment 4 David Herrmann 2015-07-31 12:04:44 EDT
Another race condition fixed [1]. I verified that this indeed fixes the issues with `rolectl`.

Please reopen if it turns up again! Thanks!
David

[1] https://github.com/systemd/systemd/pull/806
Comment 5 Zbigniew Jędrzejewski-Szmek 2015-08-06 22:07:41 EDT
Yep, this seems to be fixed in 224.
(At least in the sense that running 'rolectl list roles' spawns rolekit.service. It doesn't produce any output here, but this seems to be a different issue.)

Note You need to log in before you can comment on or make changes to this bug.