Bug 1248788 - Migration intermittently fails with the error "Alias not found for device type graphics during migration at destination host" [NEEDINFO]
Summary: Migration intermittently fails with the error "Alias not found for device typ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.3
Hardware: All
OS: Linux
high
high
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Francesco Romani
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-30 20:32 UTC by Allie DeVolder
Modified: 2019-08-15 05:04 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 21:10:35 UTC
oVirt Team: Virt
avoss: needinfo?
mgoldboi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 44669 None None None Never
oVirt gerrit 45018 None None None Never

Description Allie DeVolder 2015-07-30 20:32:11 UTC
Description of problem: Migration intermittently fails with the error "Alias not found for device type graphics during migration at destination host" 

Version-Release number of selected component (if applicable):
rhevm-3.5.3.1-1.4.el6ev.noarch 
vdsm-4.16.20-1.el7ev.x86_64


How reproducible:
Unknown

Steps to Reproduce:
1. Attempt to migrate a VM

Actual results:
Migration failed, with the following error in vdsm.log:
Alias not found for device type graphics during migration at destination host

Expected results:
Successful migration

Additional info:

Comment 2 Omer Frenkel 2015-08-02 10:17:23 UTC
please attach relevant engine, vdsm and libvirt (source host) logs

Comment 8 Francesco Romani 2015-08-11 07:40:02 UTC
> Migration failed, with the following error in vdsm.log:
> Alias not found for device type graphics during migration at destination host

This is confusing and misleading - and indeed mislead the investigation here. Will fix in a low-priority patch.

Comment 9 Francesco Romani 2015-08-11 08:12:15 UTC
(In reply to Francesco Romani from comment #8)
> > Migration failed, with the following error in vdsm.log:
> > Alias not found for device type graphics during migration at destination host
> 
> This is confusing and misleading - and indeed mislead the investigation
> here. Will fix in a low-priority patch.

here: https://gerrit.ovirt.org/44669

Comment 12 Ilanit Stein 2015-08-19 11:18:57 UTC
Would you please add steps to reproduce?

Comment 13 Francesco Romani 2015-08-19 12:35:24 UTC
(In reply to Ilanit Stein from comment #12)
> Would you please add steps to reproduce?

The only change we made to fix this bug was the removal of the misleading message as per

https://bugzilla.redhat.com/show_bug.cgi?id=1248788#c9

to reproduce:
- migrate any VM, verify the message
  "Alias not found for device type graphics"
  is present (hence the issue being addressed) on destination side
- apply fix (or use fixed build)
- migrate any VM, verify migration succeeds, graphic console works and message is gone

Comment 15 Israel Pinto 2015-11-05 12:58:40 UTC
Verify with:
RHEVM: rhevm-tools-3.6.0.3-0.1
vdsm:vdsm-4.17.10.1-0.el7ev
libvirt: libvirt-1.2.17-13.el7

Scenario:
1. Migration VM
2. Check in vdsm.log the message in not on source / destination hosts
and also in engine log.

Results:
Message not found in vdsm.log and engine.log

Comment 18 Francesco Romani 2016-01-19 15:13:22 UTC
Since the fix was just about noise reduction in the logs, I don't think this feature deserves a mention in the docs.

Comment 20 errata-xmlrpc 2016-03-09 21:10:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.