Bug 1248821 - date picker on all subscriptions tab throws TypeError
date picker on all subscriptions tab throws TypeError
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks: 1246123
  Show dependency treegraph
 
Reported: 2015-07-30 18:04 EDT by Adrian Likins
Modified: 2015-11-19 06:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
date-picker widget (77.85 KB, image/png)
2015-08-06 03:07 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Adrian Likins 2015-07-30 18:04:15 EDT
Description of problem:
Go to "All Available Subscriptions" tab, click the date picker.

Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/widgets.py", line 731, in _button_clicked
    self.get_parent())
TypeError: argument parent: Expected Gtk.Window, but got gi.overrides.Gtk.Box

And the date picker widget doesn't show up.
Comment 1 Adrian Likins 2015-07-30 18:15:27 EDT
pr at https://github.com/candlepin/subscription-manager/pull/1247
Comment 2 Chris "Ceiu" Rog 2015-07-31 16:03:44 EDT
commit 2f09e5c8889d6131b8df6ddc218c52091f69240a
Author: Adrian Likins <alikins@redhat.com>
Date:   Fri Jul 31 11:53:35 2015 -0400

    1248821: Add Gtk.Window to ga_gtk2.Gtk
    
    This was missing, and widgets.DatePicker uses and would
    fail on gtk2.

commit 236317388435418d273aae76b9226a60ab346858
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu Jul 30 18:13:01 2015 -0400

    1248821: All subs date picker was failing.
    
    DatePicker is a subclass of HBox, so self.get_parent()
    doesn't make sense, so clicking on the date picker would
    throw an error:
    
    TypeError: argument parent: Expected Gtk.Window, but got
    gi.overrides.Gtk.Box
Comment 4 Shwetha Kallesh 2015-08-06 03:07:13 EDT
Created attachment 1059732 [details]
date-picker widget

Marking verified as date-picker widget opens
[root@dhcp35-236 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.26.11-1
subscription management rules: 5.12
subscription-manager: 1.15.9-3.el7
python-rhsm: 1.15.4-2.el7
Comment 5 errata-xmlrpc 2015-11-19 06:50:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.