Bug 1248831 - missing dependency on recordmydesktop
missing dependency on recordmydesktop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fros (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 18:59 EDT by leinfeva
Modified: 2016-11-30 19:49 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-06 13:06:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leinfeva 2015-07-30 18:59:58 EDT
Description of problem:

fros require 'recordmydesktop' for record the screencast. the problem is that fros is installed by default  but recordmydesktop no. 

Version-Release number of selected component (if applicable):

[leinfeva@new-host-5 ~]$ rpm -qa |grep -i fros
fros-recordmydesktop-1.1-4.fc23.noarch
fros-1.1-4.fc23.noarch
[leinfeva@new-host-5 ~]$ 


How reproducible:


Steps to Reproduce:
1. run fros from terminal
2. select the window to record
3. choose record
4. crash

terminal output:

File "/usr/lib/python3.4/site-packages/pyfros/controls.py", line 104, in _start_recording
    res = self.controller.Screencast()
  File "/usr/lib/python3.4/site-packages/pyfros/plugins/screencastrecordmydesktop.py", line 114, in Screencast
    self.recorapp = Popen(args, stdin=PIPE, stdout=PIPE, close_fds=True)
  File "/usr/lib64/python3.4/subprocess.py", line 859, in __init__
    restore_signals, start_new_session)
  File "/usr/lib64/python3.4/subprocess.py", line 1457, in _execute_child
    raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] No such file or directory: 'recordmydesktop'
[leinfeva@new-host-5 ~]$ 

Additional info:

I've record a simple video of this.

https://www.youtube.com/watch?v=ZUIsEYIJURg
Comment 1 Jakub Filak 2015-08-03 01:22:17 EDT
Thank you for the bug report.

fros was installed because it is a dependency of libreport-gtk and it does not provide any screen-casting functionality. fros itself is just the bar with buttons you use to start/stop recording. So, fros itself must not have a dependency on any screen-casting backend.

On the other hand, fros-recordmydesktop is a plug-in for fros which defines a bridge to recordmydesktop, which can record your desktop. The package was installed because fros-recordmydesktop is placed in several comps groups [1] and you can remove that package without removing any other package. If you remove it, fros will start exiting with "No screencasting plugin is available ..." error and that is correct behavior, because fros needs a plug-in to be able to do screen-casting.

I hope I gave you enough arguments to understand why I think that the package that misses the dependency is fros-recordmydesktop.


1: https://git.fedorahosted.org/cgit/comps.git/tree/comps-f23.xml.in
Comment 2 leinfeva 2015-08-03 01:52:58 EDT
Hello Jakub, first thank for the reply. before posting this report i've ask in mail list of testing if this is really a bug and one user answer that yes. 

This is the only reason for post this. but i really appreciate all your info. if you consider please this report. now i give karma +1 in bodhi.

thanks and excuse my poor english.

regards :)
Comment 3 Jakub Filak 2015-08-03 04:36:30 EDT
(In reply to leinfeva from comment #2)
> Hello Jakub, first thank for the reply. before posting this report i've ask
> in mail list of testing if this is really a bug and one user answer that
> yes. 
> 
> This is the only reason for post this.

You did the right thing.

> but i really appreciate all your info.

I find the documentation of fros not very verbose and I wanted to provide a comprehensive explanation to clarify the situation around fros and its purpose.

> if you consider please this report. now i give karma +1 in bodhi.

This bug report is valid and I am going to fix it, however you have correctly updated the karma as this bug report has nothing common with bug #1231482 for which the bodhi update was created.

Excellent job. Thank you!
Comment 4 Fedora Update System 2015-08-25 03:13:45 EDT
fros-1.1-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14187
Comment 5 Fedora Update System 2015-08-26 00:25:52 EDT
fros-1.1-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update fros'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14187
Comment 6 Fedora Update System 2015-09-06 13:05:52 EDT
fros-1.1-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.