Bug 1248843 - virt-manager can not find qemu-dm after upgrading to fedora 22
virt-manager can not find qemu-dm after upgrading to fedora 22
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Young
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 20:47 EDT by Lloyd Kvam
Modified: 2015-10-23 13:21 EDT (History)
5 users (show)

See Also:
Fixed In Version: xen-4.5.1-11.fc23 xen-4.5.1-13.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-23 13:21:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lloyd Kvam 2015-07-30 20:47:38 EDT
Description of problem:
Unable to start domains because the qemu-dm emulator was not found

Version-Release number of selected component (if applicable):
xen-runtime-4.5.1-2.fc22.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
virsh --connect xen:/// capabilities | grep lib64
      <emulator>/usr/lib64/xen/bin/qemu-dm</emulator>
the actual path is
      /usr/lib/xen/bin/qemu-dm

I did a symlink from /usr/lib674/xen to /usr/lib/xen so the file could be found.  I suppose the correct fix would be to adjust the capabilities.

This happened after upgrading from fedora-20 to fedora-22 using fedup.
Comment 1 Ting-Wei Lan 2015-08-04 05:07:40 EDT
I also see this problem. virt-manager cannot complete installation of fullvirt domains because /usr/lib64/xen/bin/qemu-dm cannot be found.
Comment 2 Fedora Update System 2015-10-07 17:22:49 EDT
xen-4.5.1-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7bb70880ca
Comment 3 Fedora Update System 2015-10-08 06:30:46 EDT
xen-4.5.1-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xen'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7bb70880ca
Comment 4 Fedora Update System 2015-10-09 11:31:43 EDT
xen-4.5.1-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 5 Ting-Wei Lan 2015-10-09 12:39:08 EDT
Will an update be submitted for Fedora 22?
Comment 6 Fedora Update System 2015-10-13 12:31:24 EDT
xen-4.5.1-13.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fca1900745
Comment 7 Fedora Update System 2015-10-14 05:27:40 EDT
xen-4.5.1-13.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xen'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fca1900745
Comment 8 Fedora Update System 2015-10-23 13:21:33 EDT
xen-4.5.1-13.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.