This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1248859 - [aarch64] crash command "bt -f" Segmentation fault
[aarch64] crash command "bt -f" Segmentation fault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: crash (Show other bugs)
7.2
aarch64 Unspecified
high Severity high
: rc
: ---
Assigned To: Dave Anderson
Qiao Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 23:24 EDT by Qiao Zhao
Modified: 2015-11-19 07:00 EST (History)
4 users (show)

See Also:
Fixed In Version: crash-7.1.2-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:00:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qiao Zhao 2015-07-30 23:24:30 EDT
Description of problem:
"bt -f" command will trigger Segmentation fault.
detail info: http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2015/07/10323/1032336/2115170/32833830/crash.vmcore.log

https://beaker.engineering.redhat.com/jobs/1032336

Version-Release number of selected component (if applicable):
4.2.0-0.rc3.15.el7.aarch64
crash-7.1.2-1.el7.aarch64
kexec-tools-2.0.7-28.el7.aarch64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Dave Anderson 2015-08-03 10:06:52 EDT
Qiao,

Did you save the vmcore file?

It's typically impossible to debug crash issue that occur with dumpfiles
without having the vmcore.
Comment 3 Dave Anderson 2015-08-03 11:28:13 EDT
I have another vmcore and can reproduce the problem.

This was introduced by this RHEL7.2 bugzilla:

  BZ #1227508 - Enhancement to the ARM64 backtrace capability
  https://bugzilla.redhat.com/show_bug.cgi?id=1227508

It requires a one-line fix.
Comment 4 Dave Anderson 2015-08-03 13:59:28 EDT
Fix applied in the upstream crash-utility git repository:

https://github.com/crash-utility/crash/commit/9c102f994856d1de5a62644822d07a99318073cb

  Fix for a segmentation violation generated by the ARM64 "bt -[f|F]" 
  options when analyzing the active tasks in vmcores generated by the
  kdump facility.  This bug is a regression that was introduced in 
  crash-7.1.2 by commit 15a58e4070486efa2aa965bdd636626e62b65cc7, which
  was an enhancement of the ARM64 backtrace capability for active tasks
  in kdump vmcores.
  (anderson@redhat.com)
Comment 8 errata-xmlrpc 2015-11-19 07:00:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2102.html

Note You need to log in before you can comment on or make changes to this bug.