Bug 1248873 - [whql][netkvm]Job named NDISTest6.5-InvalidPackets failed with HCK on win8-32/win8-64(build 106)
Summary: [whql][netkvm]Job named NDISTest6.5-InvalidPackets failed with HCK on win8-3...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337 1609607
TreeView+ depends on / blocked
 
Reported: 2015-07-31 05:21 UTC by Yu Wang
Modified: 2018-07-30 03:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
: 1609607 (view as bug list)
Environment:
Last Closed: 2016-11-04 08:48:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yu Wang 2015-07-31 05:21:39 UTC
Description of problem:

Job named NDISTest6.5-InvalidPackets  failed with HCK on win8-32/win8-64(build 106)

Version-Release number of selected component (if applicable):

virtio-win-prewhql build 106

How reproducible:

6/6

Steps to Reproduce:
1.run command
Client:
/usr/libexec/qemu-kvm -name 106NICWIN832CNH -enable-kvm -m 3G -smp 4 -uuid a3b6e509-b32b-45a9-ba34-237af4d76621 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/106NICWIN832CNH,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=106NICWIN832CNH,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_enterprise_x86_dvd_917587.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=106NICWIN832CNH.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:4a:7c:b8:76,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:67:52:84:33,bus=pci.0,mq=on,vectors=10

Support:
t/usr/libexec/qemu-kvm -name 106NICWIN832SNH -enable-kvm -m 3G -smp 4 -uuid ccb6d877-0378-4618-bd75-a0b09958c721 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/106NICWIN832SNH,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=106NICWIN832SNH,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_enterprise_x86_dvd_917587.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=106NICWIN832SNH.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:02:16:9f:d9,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:3d:15:b3:05,bus=pci.0,mq=on,vectors=10
2.run job NDISTest6.5-[2 machines]-InvalidPackets

Actual results:

fail with "10 total breakpoints were hit in the protocol driver while this test was executing"

Expected results:
Pass 

Additional info:

The hck log(named 106-netkvm-2012R2-mini8rss-2c.zip) is located in http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/virtio-win/

Comment 6 lijin 2015-08-17 02:57:18 UTC
win10-64 guest hit the similar issue when run 105 netkvm whql test job "NDISTest6.5-InvalidPackets",job failed with queues=4 but passed with single queue.

Comment 8 Yan Vugenfirer 2016-01-05 06:57:32 UTC
Please retest with latest build

Comment 9 Peixiu Hou 2016-01-05 09:10:02 UTC
Hello Yan,

Rerun the test case NDIS6.5 - InvalidPackets passed with multiqueue on build 111.  -win8.1_32 

Rerun the test case NDIS6.5 - InvalidPackets passed with multiqueue on build 111.  -win10_64 


Best Regards!
Peixiu Hou

Comment 10 Yan Vugenfirer 2016-01-05 09:43:28 UTC
(In reply to Peixiu Hou from comment #9)
> Hello Yan,
> 
> Rerun the test case NDIS6.5 - InvalidPackets passed with multiqueue on build
> 111.  -win8.1_32 
> 
> Rerun the test case NDIS6.5 - InvalidPackets passed with multiqueue on build
> 111.  -win10_64 
> 
> 
> Best Regards!
> Peixiu Hou

Thanks!

Comment 11 lijin 2016-01-05 10:03:28 UTC
change status to verified according to comment#9

Comment 14 errata-xmlrpc 2016-11-04 08:48:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.