Bug 1248887 - AFR: Make [f]xattrop metadata transaction
AFR: Make [f]xattrop metadata transaction
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
: Triaged
Depends On:
Blocks: 1248890
  Show dependency treegraph
 
Reported: 2015-07-31 02:05 EDT by Krutika Dhananjay
Modified: 2016-06-16 09:28 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1248890 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:28:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-07-31 02:05:26 EDT
Description of problem:
(f)xattrop fops need to be made into transactions in order for these to work correctly when requested by translators that are above AFR in the client graph.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-07-31 02:06:01 EDT
REVIEW: http://review.gluster.org/11809 (cluster/afr: Make [f]xattrop metadata transaction) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Anand Avati 2015-07-31 02:11:40 EDT
REVIEW: http://review.gluster.org/11809 (cluster/afr: Make [f]xattrop metadata transaction) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Anand Avati 2015-08-21 06:53:40 EDT
REVIEW: http://review.gluster.org/11809 (cluster/afr: Make [f]xattrop metadata transaction) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Anand Avati 2015-08-30 03:45:52 EDT
COMMIT: http://review.gluster.org/11809 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit b0e125e937cbf4bb02baaa799ff4968a4d1cb1d0
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Sun Jul 26 11:19:28 2015 +0530

    cluster/afr: Make [f]xattrop metadata transaction
    
    Problem:
    When xlators above afr do [f]xattrop when one of the bricks is down, after the
    brick comes backup, the metadata is not healed because [f]xattrop is not
    considered a transaction.
    
    Fix:
    Treat [f]xattrop as transaction so that changes done by xlators above afr are
    marked for heal when some of the bricks were down at the time of [f]xattrop.
    
    Change-Id: Iea180f9a456509847c3cd8d5d59a0cdc2712d334
    BUG: 1248887
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11809
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 5 Niels de Vos 2016-06-16 09:28:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.