Bug 124889 - autofs does not remove the service when uninstalled
Summary: autofs does not remove the service when uninstalled
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Moyer
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-01 04:18 UTC by petrosyan
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 10:49:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description petrosyan 2004-06-01 04:18:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
autofs leaves a dead symlink in /etc/rc5.d after uninstalling autofs
by running rpm -e autofs hesiod

It should remove all of its symlinks from /etc/rc[0-6].d directories
when being uninstalled.

Version-Release number of selected component (if applicable):
autofs-4.1.2-2

How reproducible:
Always

Steps to Reproduce:
1. Remove autofs ( rpm -e autofs hesiod )
2. $ ls -l /etc/rc5.d/S28autofs
lrwxrwxrwx  1 root root 16 May 20 10:34 /etc/rc5.d/S28autofs ->
../init.d/autofs
3. this is a dangling symlink since /etc/init.d/autofs does not exist
anymore.

Comment 1 Jeff Moyer 2004-06-02 15:51:09 UTC
Thanks.  I'll fix this in the next update.


Note You need to log in before you can comment on or make changes to this bug.