Bug 124893 - gcc34 package exists but no gcc34-objc package does
gcc34 package exists but no gcc34-objc package does
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc34 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-01 01:36 EDT by Alex Perez
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-08 06:23:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Perez 2004-06-01 01:36:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
GCC 3.4 is included in Fedora Core (named gcc34), but there is no
component gcc34-objc Objective-C runtime (libobjc) for gcc34. I am
forced to use the gcc-objc (gcc v3.3.3) package which contains one
known major bug and is significantly inferior (and much slower) than
that of the libobjc which was released along with gcc 3.4.

Andrew Pinski, one of the two GCC libobjc maintainers, has verified
the above claims. I have daily contact with him. For what it's worth,
the current libobjc in GCC cvs is still 100% ABI compatible with gcc
3.3 or 3.4, according to Andrew, and it contains significant
improvements over the stock 3.4 libobjc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try to install gcc34-objc. It doesn't exist.
2. 
3.
    

Additional info:
Comment 1 Jakub Jelinek 2004-06-08 06:23:15 EDT
This is on purpose.  gcc34* packages were added to FC2 just because
a couple of Java packages needed 3.4 gcj and C/C++ are prerequisites
of Java.  No other frontend has been added and ObjC was/will not be
an exception.

FC3 will be built with GCC 3.4.

Note You need to log in before you can comment on or make changes to this bug.