Bug 1248974 - Update breaks bluetooth in GNOME on macbook pro
Update breaks bluetooth in GNOME on macbook pro
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 04:58 EDT by Gerard Ryan
Modified: 2015-08-12 03:05 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-4.1.4-100.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 02:58:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Ryan 2015-07-31 04:58:51 EDT
Description of problem:
With kernel-4.0.8-300.fc22.x86_64 bluetooth works fine, but with either kernel-4.1.2-200.fc22.x86_64 or kernel-4.1.3-200.fc22.x86_64, bluetooth on my macbook is broken in GNOME

Version-Release number of selected component (if applicable):
kernel-4.1.2-200.fc22.x86_64
kernel-4.1.3-200.fc22.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Update to kernel-4.1.2-200.fc22.x86_64
2. Try to connect bluetooth device (e.g. mouse)
3. Notice that bluetooth settings in GNOME shell seems broken

Actual results:
Bluetooth settings dialog is not listing devices, device does not connect automatically

Expected results:
Previously paired device connects automatically; devices in range are shown in dialog.


Additional info:
I think changing of screen brightness may also be affected by this update, but I haven't had a chance to verify that yet.
Comment 1 Gerard Ryan 2015-08-04 13:07:23 EDT
Here's some dmesg output related to Bluetooth:

[grdryn@redhat ~]$ dmesg -k | grep Bluetooth
[    2.490166] usb 1-8.3: Product: Bluetooth USB Host Controller
[   10.746302] Bluetooth: Core ver 2.20
[   10.746424] Bluetooth: HCI device and connection manager initialized
[   10.746426] Bluetooth: HCI socket layer initialized
[   10.746428] Bluetooth: L2CAP socket layer initialized
[   10.746435] Bluetooth: SCO socket layer initialized
[   10.752110] Bluetooth: hci0: BCM: Read verbose config info failed (-16)
[   10.897048] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   10.897050] Bluetooth: BNEP filters: protocol multicast
[   10.897053] Bluetooth: BNEP socket layer initialized


^It was the "hci0: BCM: Read verbose config info failed (-16)" that shows up in red that made me think of providing this info. Let me know if there's any other info that you would like me to provide.
Comment 2 Kristjan Kullerkann 2015-08-06 03:19:40 EDT
Looks like bug has been identified in upstream:
https://bugzilla.kernel.org/show_bug.cgi?id=100651

Perhaps someone could apply the patch/build kernel package for us to test?
Comment 3 Josh Boyer 2015-08-06 07:26:09 EDT
(In reply to Kristjan Kullerkann from comment #2)
> Looks like bug has been identified in upstream:
> https://bugzilla.kernel.org/show_bug.cgi?id=100651
> 
> Perhaps someone could apply the patch/build kernel package for us to test?

If I read the bug correctly, it was included in upstream 4.1.4.  We have that built and in updates-testing already.  You should be able to test it from there and let us know.
Comment 4 Kristjan Kullerkann 2015-08-06 07:46:08 EDT
Sorry, I'm unable to find 4.1.4 in updates-testing. It hasn't been staged yet?
Comment 5 Kristjan Kullerkann 2015-08-06 08:03:57 EDT
Never mind, found it:

https://admin.fedoraproject.org/updates/kernel-4.1.4-200.fc22?_csrf_token=6ef7cba4bc74cb731bb96312542a36026891a8aa

It's fixed in 4.1.4, thank you!
Comment 6 Fedora Update System 2015-08-06 10:53:32 EDT
kernel-4.1.4-200.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kernel-4.1.4-200.fc22
Comment 7 Fedora Update System 2015-08-06 10:54:30 EDT
kernel-4.1.4-100.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-4.1.4-100.fc21
Comment 8 Fedora Update System 2015-08-07 08:54:33 EDT
Package kernel-4.1.4-200.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-4.1.4-200.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12908/kernel-4.1.4-200.fc22
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2015-08-12 02:58:10 EDT
kernel-4.1.4-200.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2015-08-12 03:05:20 EDT
kernel-4.1.4-100.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.