Bug 1248987 - User can edit connection profile and save it without password
User can edit connection profile and save it without password
Status: CLOSED DEFERRED
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
unspecified
Unspecified Mac OS
medium Severity medium
: ---
: ---
Assigned To: Barry LaFond
Filip Elias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 05:36 EDT by Matus Makovy
Modified: 2016-02-05 05:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Users can edit their connection profile and save it without being required to enter their password for it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 05:15:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2594 Major Open User can edit connection profile and save it without password 2016-08-09 01:32 EDT

  None (edit)
Description Matus Makovy 2015-07-31 05:36:35 EDT
During the creation of connection profile TD forces user to enter some password, but when user tries to edit finished connection profile, they are able to save CP without password.

There is something clearly wrong. Personally, I don't see a point in forcing user to enter some password (they can type in the password in import dialogue). If we want to force the user to input password (during creation) then edit dialogue should be fixed.

See video attached in JIRA

Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:
Comment 1 Matus Makovy 2016-02-05 05:15:32 EST
Closing this since we are tracking issues for tooling only in JIRA from now on.

Note You need to log in before you can comment on or make changes to this bug.