Bug 124902 - Shortcuts stop working if > 50 entered
Shortcuts stop working if > 50 entered
Status: CLOSED WONTFIX
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-01 07:26 EDT by Graham Lally
Modified: 2010-09-03 10:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-03 10:33:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Lally 2004-06-01 07:26:59 EDT
Description of problem:

ccm-ldn-shortcuts application uses a c.ad.util.Cache object of size 50
to keep track of URL shortcuts. I think this leads to a problem when
you have more than 50 shortcuts whereby some (whichever get deleted
when new ones get added) no longer work, i.e. they return a 404 (and
the target URL still works fine).

Version-Release number of selected component (if applicable):

Verified in 5.2 and 6.0 Unsure of nightly.

How reproducible:

Consistently, but limited testing due to time taken to enter a
bazillion shortcuts.

Steps to Reproduce:
1. Add shortcut at /shortcuts/admin || /admin/shortcuts
2. GOTO 1 unless ($#shortcuts > 50)
3. Clicky clicky on the oldest shortcuts.
  
Actual results:

404 page referring to the shortcut name (e.g. "/my-shortcut/ not
found", rather than "/target-url/ not found")

Expected results:

Shortcut works, forwards you to intended page.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.